#8 $uid problem for assigning a domain

v0.0.3
closed-fixed
Corey
None
5
2005-08-13
2005-08-13
marcoparco
No

(and maybe somewhere else :)

auth.php, line: 606

//If we have a $did and no $uid, we're an admin looking
at a user's domain page. Get the $uid
...

this causes problem when assigning a domain to "No
One", because in domains.php line: 28 we are going to
execute this query:
$sql = "update domains set uid = '$uid' where id = '$did'";

TEMPORARY FIX:
$sql = "update domains set uid = '".$_POST[uid]."'
where id = '$did'";

ciaooo

Discussion

  • Corey

    Corey - 2005-08-13
    • status: open --> closed
     
  • Corey

    Corey - 2005-08-13

    Logged In: YES
    user_id=1066333

    Thank you for this report. The problem is now fixed, and is
    set for release in 0.0.4

    [code]

    } else if($action == "change") {

    // only an admin can do this
    if(!is_admin()) goto("users.php");

    $sql = "update domains set uid = '$_POST[uid]' where id =
    '$did'";
    mysql_query($sql);

     
  • Corey

    Corey - 2005-08-13
    • assigned_to: nobody --> cormander
    • status: closed --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks