I don't know how to install it

Help
King84
2009-12-13
2013-05-28
  • King84

    King84 - 2009-12-13

    Hello everybody,
    I'm kind of new to Linux (been having it for a month or so). I have Karmic Koala Ubuntu 9.10 on a HP Pavilion dv6000 notebook. I'm a bit proud I cancelled Vista and put on Linux on my own, on it.
    I just don't know how to install rakarrack 0.3.0 though, and it isn't written anywere. I have searched the internet for many forums and blogs, but can't find it anywhere.
    In the section guide http://rakarrack.sourceforge.net/help.html there isn't written.
    Can you all help me, please?

     
  • Transmogrifox

    Transmogrifox - 2009-12-13

    The next Ubuntu release, Lucid Lynx, will include Rakarrack as a standard package that you may install using package management tools.  This is scheduled for April 2010.

    Until then, you will need to compile from source.  If you're going to all the trouble of compiling from source,  you should compile from current CVS as the rakarrack team has recently made some significant bug fixes.

    The first step is to get the source code.  You need to open a command terminal (sorry) and enter the following commands:

    cvs -d:pserver:anonymous@rakarrack.cvs.sourceforge.net:/cvsroot/rakarrack login

    when the prompt ask for password … just press enter

    cvs -z3 -d:pserver:anonymous@rakarrack.cvs.sourceforge.net:/cvsroot/rakarrack co -P rakarrack2

    The above can be found here http://rakarrack.sourceforge.net/dl.html

    The next part is to get all the dependencies and extra tools you need to compile programs on your computer.

    libfltk1.1

    libxpm

    libjack100.0

    libasound2

    aconnect

    jackd

    fftw3

    Use the above names as search criteria in Synaptic Package Manager.  If you aren't familiar with where to find this program in your menus, you can type in a terminal:

    sudo synaptic

    Then type your password.

    After you have searched and found packages with the above names in it, you also have to install any packages with a "-dev" extension to make sure you have all recent library functions supported.

    Next you also need autotools and linux-headers.  Search autogen, and you'll find a package that is able to support that.  If running autogen.sh below fails, then you have installed the wrong thing, and you'll need to try again (sorry it's vague, I am in the middle of something else right now).

    So, enter the rakarrack2 directory.  If you executed the cvs command in your home directory, then you can type "cd rakarrack2"

    Then type these:
    autogen.sh

    configure     (make sure this passes checks for libraries)

    make     (compilation will fail if you have missed some of the required dependencies. Post back to this thread if you are having problems)

    make install  (don't run this until 'make' -above- has completed successfully).

    After you run make install, then the program is installed and ready to use.

    You will likely want this program to help with jack:

    qjackctl

    You will need to start that program and get jack running successfully, then start rakarrack.  Use qjackctl to route line in to rakarrack, and rakarrack out to your line out.

    I hope that is detailed enough to get you going.  Post back here if you run into road blocks.

    Take care.

     
  • King84

    King84 - 2009-12-14

    Hello!
    Thanks sooo much for answerring me.
    The first thing I have to admit is that I didn't know where to find and how to install the various libftk libxpm and so on…..Now I just pasted the two "cvs" lines into terminal (your "sorry" word made me laugh :-) ).
    Now I just opened synaptic and installed libfltk1.1,
    I don't understand what's the difference between "name" and "name-dev" in libraries.
    can't find libxpm, but I see in my package manager I already have installed libxpm4 1:3.5.7-2 (I don't know what it means, but I pretend it's alright).
    Now just installed libjack0.100.0-0, even if I already had installed libjack0 (who cares, anyway).
    I already have libasound2, alright.
    Can't find aconnect, only kaconnect, aconnectgui (I'm installing this, with the gui), and I already had alsa-utils installed.
    Installed jackd (who asked me to install two more things, OK).
    Can't find fftw3, I see I have already installed fftw2, I can only find libfftw3-doc and root-plugin-fftw3, but who cares, I'm installing both :-).
    (It's downloading something like 37MB of things….huh?).
    Ok, done everything with synaptic and -dev's!
    autogen.sh chapter:
    I wrote "autogen.sh" in terminal, after moving into my rakarrack2 directory and it said "command not found". Searched the internet and noticed I had to write "./autogen.sh" and at the end it says "Done generating build scripts". OK!"
    Same thing with "configure", instead of "./configure" (me n00b!!!!). However it said a lot of Yes and some little No.
    Guess I'm continuing.
    Wrote "make", though I had a doubt if writing "./make". It worked a lot and then it stopped, it wrote a lot of things.
    Then "make install" and it says all this:
    ale@Ale:~/rakarrack2$ make install
    Making install in src
    make: ingresso nella directory «/home/ale/rakarrack2/src»
    make: ingresso nella directory «/home/ale/rakarrack2/src»
    test -z "/usr/local/bin" || /bin/mkdir -p "/usr/local/bin"
      /usr/bin/install -c rakarrack '/usr/local/bin'
    /usr/bin/install: impossibile creare il file regolare "/usr/local/bin/rakarrack": Permesso negato
    make: ***  Errore 1
    make: uscita dalla directory «/home/ale/rakarrack2/src»
    make: ***  Errore 2
    make: uscita dalla directory «/home/ale/rakarrack2/src»
    make: ***  Errore 1
    ale@Ale:~/rakarrack2$

    I'm scared :-/.
    Wrote qjackctl and it opened a window, nice.
    Well….. I think once again I couldn't install it goodly.
    I wrote "rakarrack2" in the terminal and here's the answer:

    ale@Ale:~/rakarrack2$ rakarrack2
    rakarrack2: command not found

    :-( Ah, I guess I'm waiting for lucid lynx. Poor me.
    I still can't find ti anywhere.. neither in the Applications, nor in the Audio.

     
  • Transmogrifox

    Transmogrifox - 2009-12-14

    You did pretty well for a noob.  Kudos on finding the information about needing to use ./autogen.sh and ./configure. :)

    The reason you can't find rakarrack installed anywhere is because "make install" failed and it did not install it.

    I forgot to mention you need to use "sudo make install" so it installs as root.  Non-root user doesn't have permission to put programs in the locations that make install wants to put them.  "sudo" causes Ubuntu to execute the command as root, who is lord of the Unix.  Windows uses UAC, and doesn't ask for a password.  You just click ok and it does it.  On a Windows system, you are pretty much running as Administrator, so you don't have these problems.  On most Linux systems you don't default login as root, for security reasons.  This stops unwanted programs from really messing up core parts of your file system without you having to stop and type a password.  At that point, I hear Pete Puma yelping "Ya told me to, Ya told me to, Ya told me to!!!!"  :)  …and it's your own fault you explicitly gave malware permission to pwn your system.

    Rakarrack, and many software programs are developed using functions from libraries that are more on the "cutting edge" of development.  Packages without "name-dev" don't support some of the functions called from within the program.  Ubuntu includes this extra stuff for developers and "cutting edge" applications as packages with a -dev extension because these are not needed in programs compiled for the main stable repository.  I don't know how to explain it simply…basically this is the way developers get to work with the most recent libraries and help work out bugs so when this whole group of programs flows downstream to the stable release, most of the bugs have been resolved.

    By the time a software package is available in your distribution's repository, the developers and package maintainers have figured out all this stuff that needs to be included with the package, and it happens automagically when you click "install" on your package manager.

    The nice thing if you succeed at compiling this from source is that CVS updates and re-compiling is really simple.  It is just as easy as, cvs update -d,  sudo make && sudo make install … until we add something that makes calls to a library you don't have installed…then you need to go searching for it and install it….I love package managers.  They do all this stuff for you and you don't have to think about it. :)

    Anyway, here is your problem with make:

    sudo make  (I don't think you actually have to execute this as root, but I often do--some might frown at me for that :)  )

    sudo make install

    The error returned tells you that your non-root user doesn't have permission to install the software.  If make was successful, then you are almost there.  You only need to run these commands as root, and things will be groovy :)

    If more problems spring out, please copy the output of sudo make, and output of sudo make install.

    Believe me, you are really close to having successfully compiled the program. 

     
  • Transmogrifox

    Transmogrifox - 2009-12-14

    ale@Ale:~/rakarrack2$ rakarrack2 rakarrack2: command not found

    By the way, when make install is successful you will find this in your applications menu. 

    If you do want to execute it from the command line, it's just "rakarrack".

    I like your username & host name, Ale.  I like Ale.

     
  • King84

    King84 - 2009-12-14

    Alright transmogrifox, I succeeded in it!
    I did that sudo make install thingy and now I'm done and it really works nicely (though the blueish screen kills me, at some times).
    Thanks a lot for helping me, I hope our discussion will be apreciated also by other users who need help as I did!
    p.s. Ale is not intende like beer eh eh, I also like it though. My name's Alessandro, I'm 25 and I'm from Italy (well, Rep. of San Marino exactly)

     
  • Transmogrifox

    Transmogrifox - 2009-12-15

    Excellent.  If we had a proper FAQ, this would be one of questions addressed. 

    If you haven't already noticed, you can change the colors of Rakarrack in the settings menu.  This gets saved in your home .fltk settings file, so you don't lose it when you recompile.  Look at the project screenshots for some ideas.

    I hail from Alaska, the northern part of the other side of the world from you.  The wonder of the World Wide Web :) …  <-yup, he's druling

     
  • King84

    King84 - 2009-12-15

    Oh….It's tough to be a n00b :-P Alright I found different colour schemes available!
    Thanks again and, hey, Alaska rocks! :-) It' cool thinking I just woke up and maybe you are going to go to sleep :-)

     
  • anay pantoji

    anay pantoji - 2010-02-01

    ok …. i know this thread is a little old. ( yes i am a noob: just loaded ubuntu for the first time in my life the day before).
    ok to get to the point: i'm stuck at the configure part. i managed to get the autogen.sh running after typing "cd rakarrack2"

    kings@ubuntu:~/rakarrack2$ ./autogen.sh
    Generating build scripts, this might take a while.
    aclocal./autogen.sh: 36: aclocal: not found
    autoheader./autogen.sh: 37: autoheader: not found
    autoconf./autogen.sh: 38: autoconf: not found
    automake./autogen.sh: 39: automake: not found

    Done generating build scripts.
    kings@ubuntu:~/rakarrack2$ ./configure
    bash: ./configure: No such file or directory

    i tried a couple of different things like not put the "./" i even checked if the file was missing from the directory but it's there under "configure.in" in the rakarrack2 dir.

    please help. im a guitarist and i need to start recording…. long story.

     
  • Josep Andreu

    Josep Andreu - 2010-02-02

    hi ..

    autogen.sh is a script that execute autotools programs …. (aclocal autoheader autoconf and automake) you need to install the packages automake-1.9 and autoconf , I think that is the same name in ubuntu.  Also in order to compile you will need to install more pacakges …. read up this thread.

     
  • Transmogrifox

    Transmogrifox - 2010-02-02

    If you are new to Ubuntu and Linux in general, then I should mention that Synaptic Package manager is the program for installing the programs you need.  If you're at a loss for finding it, you can type 'sudo synaptic' in the command line and it will bring it up.  If you're familiar with it…then you will know where to find it.

    Search function in Synaptic will help you find the tools you need.  Type "automake" in the search bar and it should bring up some options.  Josep and I use Debian, so for the most part packages are named very similar to Ubuntu, but if the name is not exactly "automake-1.9" but looks like something very similar (even maybe a different version number…in this case I think it's the same as Debian Sid/Testing)….then that is probably what you want.

    As a general rule when trying to compile things, I will look at the README and get a list of dependencies…use those as key words in Synaptic, then install the package as well as package-dev.

    Feel free to keep asking questions as you run into problems.  Everything will go really smoothly once you have all the dependencies and helper programs installed.

     
  • Anonymous - 2010-02-03

    ok …. it's me again (anay) ….
    now i installed all the packages using the synaptic package manager………….
    but i still cant configure the damn thing …… the minute i type ./configure it just says :

    "kings@ubuntu:~/rakarrack2$ ./cofigure
    bash: ./cofigure: No such file or directory"

    im in the directory specified but still nothing. i made a check list of all the packages i may need …. and yes i even dl'd the -dev ones.
    (sorry to keep this thread going as i managed to load flstudio using wine, but i just cant figure out where im going wrong. and yes FLStudio's been working just fine)
    sorry for being sucha noob. cant help it. but atleast im learning day by day. thanks for the help so far :D.

     
  • Anonymous - 2010-02-03

    (anay here again):
    ignore the last post …. got it all sorted out ….. just re-followed the instructions from ./autogen.sh and everything went smooth ….. i guess it was just the missing packages!!!!
    thanks again for the help!!!!!!

     
  • Transmogrifox

    Transmogrifox - 2010-02-04

    Here is a command-line tip for the linux beginner:
    Auto-complete is a feature that you can activate with a tab key for any pattern.  It really helps reduce typo errors.

    Here is an example:
    if you want to type ./configure, go
    ./co<tab-key>

    it will complete as much as what is unique in that directory.  If there were two files, "config" and "configure", then
    ./co<tab-key>
    would complete to
    ./config
    then you could add a u, and tab again:
    ./configu<tab-key>
    and it would complete to
    ./configure

    There is much information on the web about the basic navigation around files and directories from the command line.   I try to include tips on this stuff because the amount of information available is overwhelming when you're starting the steep incline of the learning curve.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks