Can not load this bank....

  • Anonymous

    Anonymous - 2011-07-29

    I recently updated from an old version (0.3x i think)… and when i start the program all i get is a window whit this message (the program dies here).

    All i could google is that i have to use rakconvert to convert the old preset bank to the new version, but i don't know where it is.
    which file am i looking for? where is located? (using ubuntu 10.04 if it helps)

    if i find it but for some reason i'm not successful converting it, will rakarrack start if i delete it?

    i suppose that to install new banks y have to download the files and copy them in the same folder.. am i right?


  • Anonymous

    Anonymous - 2011-07-29

    ok… some.. progress made?

    i found in /home/.fltk/ that the program was looking for the banks in /usr/share/rakarrack
    so i went there and executed "rakonvert -c Default.rkrb" and nothing seems to go wrong…
    i end up with 3 files in the folder and when i try to run the program it crashes with the same output… "could not load thisn bank file because is from an old rakarrack version"

    if i remove the files from the folder rakarrack crashes saying: "can not load this bankfile" (the folder is empty now)
    the same happens if i leave the new files generated by "rakonvert"…

    any thoughts??

  • Josep Andreu

    Josep Andreu - 2011-07-30


    IIRC the rakconvert generate two new bank files renamed … 
    Maybe the problem is the USer Bank you have on the settings ….

    You can do two things …. the most easy is .. delete the /home/youruser/.fltk/

    If you dont want to remove your config and use your old bank … the second option is edit with a text editor …
    you will see a entry like this:

    rakarrack Bank Filename:/home/holborn/Pruebas.rkrb

    edit to file produced for rakconvert


  • Anonymous

    Anonymous - 2011-07-30

    thanks Josep!

    I tried renaming the path with no success, i received a  "segmentation violation" warning at the start of the program.
    But finally removing the file worked, in addition i can load the old bank manually so i've got all i need.


Log in to post a comment.