Error Compiling

Tim Urberg
  • Tim Urberg

    Tim Urberg - 2014-01-10


    I'm running into the same issue with no distortion on Ubuntu 12.04.3 32bit using the Ubuntu repository version of Rakarrack. So I've tried compiling it myself. I'm starting with a brand new install of Ubuntu 12.04.3 32bit on an old HP computer. Here's the CPU info:

    cat /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 15
    model : 4
    model name : Intel(R) Pentium(R) 4 CPU 2.80GHz
    stepping : 1
    microcode : 0x9
    cpu MHz : 2793.076
    cache size : 1024 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 5
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc pebs bts pni dtes64 monitor ds_cpl cid xtpr
    bogomips : 5586.15
    clflush size : 64
    cache_alignment : 128
    address sizes : 36 bits physical, 32 bits virtual

    In order to get autogen and configure to work I installed the following packages from the Ubuntu repository:


    Once all those were installed and was able to run configure successfully, I tried running make and got this error:

    Making all in src
    make[1]: Entering directory /home/tim/rakarrack/src' make all-am make[2]: Entering directory/home/tim/rakarrack/src'
    g++ -DHAVE_CONFIG_H -I. -Wall -msse2 -mfpmath=sse -ffast-math -ftree-vectorize -fvect-cost-model -pipe -fsigned-char -I/usr/include/freetype2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security -D_THREAD_SAFE -D_REENTRANT -g -O2 -MT rakarrack.o -MD -MP -MF .deps/rakarrack.Tpo -c -o rakarrack.o rakarrack.cxx
    rakarrack.cxx: In member function ‘void RKRGUI::preset_click_i(Fl_Button, void)’:
    rakarrack.cxx:23586:39: error: format not a string literal and no format arguments [-Werror=format-security]
    cc1plus: some warnings being treated as errors
    make[2]: [rakarrack.o] Error 1
    make[2]: Leaving directory /home/tim/rakarrack/src' make[1]: *** [all] Error 2 make[1]: Leaving directory/home/tim/rakarrack/src'
    [all-recursive] Error 1

    This happens with either the code from a git clone or the 0.6.1 tar file. Let me know if I missed a dependency or grabbed a wrong version.


    Last edit: Tim Urberg 2014-01-10
  • Tim Urberg

    Tim Urberg - 2014-01-10

    I was able to reproduce this with VirtualBox 4.3.6 on my Macbook Pro, here's the steps exactly as I did them.

    1. Install VirtualBox 4.3.6 and download ubuntu-12.04.3-desktop-i386.iso and create a new VM.

    1. Go through all the steps and just choose the defaults, the only thing I did different was choose 2GB of RAM and I upped the video RAM to 128MB as well as checked 3D acceleration.

    2. Start VB and choose the Ubuntu ISO

    1. Choose Install Ubuntu and the check Download updates and install third-party software and click continue

    1. Choose Erase disk and install and continue

    1. Click install now

    1. Go through, choose time zone, keyboard and login and wait for install to finish. Once finished, reboot the VM.

    2. Once rebooted, login, open a terminal and do an update

    1. Then install gnome-shell (before rebooting). While this may seem unnecessary, this was part of what I did to reproduce the problem.

    1. Once Gnome Shell is finished installing, reboot the VM and when you login choose Gnome Classic (no effects)

    1. Next open a terminal and install all the dependencies listed above to compile Rakarrack. When asked about JACK real-time priority I choose No.

    1. Do a Git clone to get the source code

    1. Run

    1. Run configure

    1. Run Make

    1. And the error occurs:

  • Tim Urberg

    Tim Urberg - 2014-01-11

    I did the same steps as above on Ubuntu 13.10 and it compiled and installed successfully so it must be an issue with 12.04.

  • Transmogrifox

    Transmogrifox - 2014-01-20

    Maybe it is a compiler version problem:
    gcc -v
    will give some output about the compiler version. Show gcc version for both 13.10 and 12.04.

    This problem is happening on a GUI related function. I would have to look deeper to determine whether it is FLTK or rakarrack, but it looks like your configure script chose to add compiler option [-Werror=format-security]. That will make it terminate compilation on certain types of warnings, including possible buffer over-runs and such.

    After you configure if you edit the generated makefile and remove this option from CXX flags and try to compile, it may succeed only with throwing warnings instead of halting compilation.

    I would also be curious to see what the CXX flags are on 13.10 to see whether it included this option.


Log in to post a comment.