Building on FreeBSD: Could not find XOpenDisplay in -lX11.

  • Sérgio Siegrist

    It happens on "configure" step. Is there any workaround?

  • Transmogrifox

    Transmogrifox - 2013-12-20

    I have only once attempted to build it on FreeBSD. I started by installing dependencies, and then ran out of time and stopped before I finished getting the system set up to do this.

    Unfortunately this is related to FLTK dependencies, and Rakarrack does not use XOpenDisplay() directly.

    One thought is to comment this check out of the configure script and see if you can build without it and cross your fingers that your FLTK and X11 versions work this out in a different way. If it is a success, then the configure script apparently is checking for something which may be implemented slightly differently on FreeBSD, but still compatible between FLTK and X11.

    Let me know if that hack has any success. If make fails, perhaps you can report where make fails and what file.

  • Sérgio Siegrist

    I'm not an expert in C, but I'm trying to do my best.
    The first time I run ./configure, I got the config.log renamed to config-firstrun.log, attached. Please, take a look. Possibly some system paths must be fixed. And I got "Could not find XOpenDisplay" message.
    I changed the "configure" file to return "yes" after every library check (resulting "configure" file attached). I don't know whether I did it the right way. However, we can see that some libraries were not found that are actually installed here (i. e. fonconfig, freetype (actually freetype2 here), fltk, jack etc.) Why are they not found? Shall I fix some paths? It generated the config.log renamed to config-secondrun.log, attached, and its output was as config.console, attached.
    So, I run make, and the output is as in make.console, attached.
    Is there something I could check or fix to complete the build? Can I help somehow?
    Thank you very much, so far.


Log in to post a comment.