CPU load when using rakarrack in ardour

2008-11-12
2013-05-28
  • Frank Rocholl

    Frank Rocholl - 2008-11-12

    Hi,

    I've got some probleme with the CPU Load of ardour when I
    use rakarrack (I do not know if this is a ardour,jackd or
    rakarrack related issue).

    My test scenario:
    I route the output of a ardour track to the input of
    rakarrack and I route the output of rakarrack to the ardour
    master output.

    Then I turn "FX on" in rakarrack.
    When I play a song everything is OK. But when I stop the
    transport the CPU load increases dramatically. The result is
    that I get the message similar to:: "Ardour is too slow..".
    And the jack connection is lost.

    When I turn the FX off while playing the CPU load does NOT
    increases, when the ardour transport stops.

    Any help would be appreciated.

    Kind Regards

    Frank

    P.S.: Some system information:
    Debian Lenny, ardour 2.6.1, rakarrack 0.2.0,
    jackd 0.109.2 in relatime mode,
    M-Audio Audiophile 24/96 sound card.

     
    • Josep Andreu

      Josep Andreu - 2008-11-12

      Hi

      Please try the CVS version,  I think this bug is solved in this version.

      In order to compile in debian lenny ... do the following:

      apt-get remove rakarrack ...

      Install the following libraries:

      libjack0.100.0-dev
      libfltk1.1-dev
      libxpm-dev
      libasound2-dev

      Get the sources:

      cvs -d:pserver:anonymous@rakarrack.cvs.sourceforge.net:/cvsroot/rakarrack login

      ( when the prompt ask for password ... just press enter)

      cvs -z3 -d:pserver:anonymous@rakarrack.cvs.sourceforge.net:/cvsroot/rakarrack co -P rakarrack2

      Then run autogen.sh  configure make make install

      Josep

       
      • Frank Rocholl

        Frank Rocholl - 2008-11-12

        Hello,

        many thanks for your help. I've installed the latest CVS version.

        When I stop transport in ardour jackd dies after getting some
        xruns  with the error:

        subgraph starting at rakarrack timed out (subgraph_wait_fd=14, status = 0, state = Running)
        jackd watchdog: timeout - killing jackd

        Frank

        P.S. my jackd settings are:
        /usr/bin/jackd -R -p128 -m -dalsa -dhw:0 -r48000 -p128 -n3

         
    • Josep Andreu

      Josep Andreu - 2008-11-13

      Hi ....

      Ummh .... that's really bad thing .... I will check ....  I think I need some luck to solve that ...

      Josep

       
    • Frank Rocholl

      Frank Rocholl - 2008-11-13

      Hi,

      good luck from my side. Greetings for your famous application.

      I hope you are able to fix, because I'ld like to use it for my recording sessions :-)

      Regards

      Frank

       
    • Josep Andreu

      Josep Andreu - 2008-11-14

      Hi

      Well ..... update your CVS sources ... and try again :)

      Here works now .... but I do it in a non elegant way .... probably I'm worst programmer in the world :)
      But ... I only know small ways to do the things ...  and I'm to old to start learning how to code.

      I was check with a Drum Machine program ... I will check now with Ardour  and hope they works too .... anyway ... they are some changes in some math functions ... I need to test if that changes the effects... but seems fine.

      Josep

       
      • Frank Rocholl

        Frank Rocholl - 2008-11-14

        Hi Josep,

        I've done some first quick tests and it seems to work now.
        Many thanks!
        I'll do some more tests later and I'll let you know the result.

        Best whishes

        Frank

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks