Cannot start anymore rakarrack

  • Joel

    Joel - 2012-12-09

    Hi everybody,

    Two weeks ago I installed rakarrack first time. Everything was working fine. And I was amazed about this great tool!

    I start to change as well some settings. 3 days ago I messed it up…
    Now I'm not able to start the program anymore.

    Here the log if I try to run it in terminal:

    Jack: JackDriver::Close
    Jack: JackConnectionManager::DirectDisconnect last: ref1 = 1 ref2 = 1
    Jack: JackGraphManager::DisconnectRefNum cur_index = 4 ref1 = 1 ref2 = 1
    Jack: JackEngine::ClientCloseAux ref = 1
    Jack: JackGraphManager::RemoveAllPorts ref = 1
    Jack: JackPosixSemaphore::Destroy name = jack_sem.1000_default_freewheel
    Jack: JackEngine::Close
    Jack: JackClientSocket::Close
    Jack: no message buffer overruns
    Jack: JackPosixThread::Stop
    Jack: ThreadHandler: exit
    Jack: Succeeded in unlocking 86577696 byte memory area
    Jack: JackShmMem::delete size = 0 index = 0
    Jack: ~JackDriver
    Jack: ~JackDriver
    Jack: Succeeded in unlocking 1040 byte memory area
    Jack: JackShmMem::delete size = 0 index = 1
    Jack: cleaning up shared memory
    Jack: cleaning up files
    Jack: unregistering server `default'

    I haven't touched anything at jack side.
    I tried as well to remove the  rakarrack.prefs, but no success
    Than I start to play with qjackctl, because it tells a problem about jack… No success
    I could manage to start rakarrack under root, by starting jack_server_control and then rakarrack

    Has anyone an idea what the problem can be?

    I'm running on open suse 12.2,  and rakarrack 6.1-2-4

    Many thanks

  • Joel

    Joel - 2012-12-09

    Hi all,

    Short update:
    I uninstalled the rakarrack package which open Suse provides
    I took the git version: rakarrack 6.2
    Did the change in rakarrack.cxx proposed here:
    And installed it.

    If I now just try to run, I get the error discribed in first post.
    If I start qjackctl and start jackd there and run afterwards rakarrack, I will get an segmentation fault, which is many times reported in the net.

    In the meantime I downloaded guitarix. And there I can start and here my guitare without problems. But as I already could try  it ones, I realy want to get it up and running again … :-(

    Is there a workaraound


  • Joel

    Joel - 2012-12-09

    Hi again,

    I will post the segmentaition fault.
    It happens when I start jackd in qjackctl and then launch rakarrack in terminal:

    rakarrack 0.6.1 - Copyright (C) Josep Andreu - Ryan Billing - Douglas McClendon - Arnout Engelen
    Try 'rakarrack -help' for command-line options.
    Jack: JackClient::SetupDriverSync driver sem in flush mode
    Jack: JackPosixSemaphore::Connect name = jack_sem.1000_default_rakarrack
    Jack: JackPosixSemaphore::Connect sem_getvalue 0
    Jack: Clock source : system clock via clock_gettime
    Jack: JackLibClient::Open name = rakarrack refnum = 3


  • Joel

    Joel - 2012-12-11

    Hi all,

    I found a workarraoud.
    I created a new user. And installed there rakarrack from the open suse repo.
    Now it works in under the new user.
    But still not in my previous/main user account.
    So there must be a mess with the settings. I copied from the working user account the .fltk folder and .jackdrc. Still doesn't work…
    I compared the terminal output from the running and breaking rakarrack start. The error seems to be the following:

    joel@Anavrin:~> Jack: JackProcessSync::TimedWait finished delta = 17395.0
    Jack: JackEngine::ClientCloseAux ref = 2
    Jack: JackEngine::ReleaseRefnum server quit
    JackTemporaryException : now quits…
    Jack: JackClientSocket::Close
    Jack: JackSocketServerChannel::BuildPoolTable size = 2
    Jack: fSocketTable i = 1 fd = 9
    Jack: fPollTable i = 1 fd = 9
    jack main caught signal 2
    Jack: JackRequest::Notification
    Jack: JackServer::Stop
    Jack: JackPosixThread::Kill
    Jack: JackEngine::NotifyClient: no callback for event = 4
    Jack: JackEngine::NotifyClient: no callback for event = 4
    Jack: JackPosixMutex::Unlock res = 1
    Unknown error…

    In google it is discribed as a latency problem from xruns. But I don't know where to change that and if it's really this problem…

    Are there other config files which I can try to copy from the running account into the failing one?

    Thanks for any help

  • Josep Andreu

    Josep Andreu - 2012-12-12


    Something is wrong on your user rakarrack config file, then what you need to do is delete the rakarrack config file, this file is located on the fltk config files folder …. that can be different on each distro because depends on the fltk config. On Debian is located on 


    The program will create a new one if the file doesent exist … then will work.
    Sorry for the delay on the answer.


  • Joel

    Joel - 2012-12-12

    Hi Josep,

    Thanks for your reply.
    That was one of my first trials. I removed the whole .fltk folder in my home directory. No success
    I copied as well the .fltk from the user account, where rakarrack is workin. No success
    And then I tried with the .fltk from the root directory. No success.

    It must be something else.
    I uninstalled rakarrack several times. Than I had a look for files which can be related to rakarrack and I removed them. And I reinstalled rakarrack. I tried the git version and the repo version of open suse. No success.

    Are there somewhere else rakarrack related files/configs.
    BTW: I removed as well .jackdrc or changed the configs…

    Still thanks for any help

  • Josep Andreu

    Josep Andreu - 2012-12-13


    They was a problem on the fltk function that reads fonts that cause segment fault … when you start rakarrack.To fix that … you need to remove this function on the code. To do that … go to the sources … and in the src directory run this:

    sed /set_fonts/'s/^/\/\//' rakarrack.cxx > lololo ; mv lololo rakarrack.cxx

    (Is not a W ar  / \ / togheter) :-)

    then run make
    try rhis … maybe can help.


  • Joel

    Joel - 2012-12-13

    Hi Josep,

    I tried that as well at very beginning to comment out this two set_fonts line and make it.
    As well without success.
    I as well removed the content in ./fontsconfig. No success.
    Nevertheless I'm very happy that it is running under my other account. I hope it will not mess up the configs there.
    It's a very nice Guitar playground :-))


  • Transmogrifox

    Transmogrifox - 2012-12-18

    rm -r ~/.fltk

    The only thing I think maybe causes the problem is related to permissions on that directory.  Assuming you don't have any other fltk programs using that dir, there will be no harm to delete it…otherwise you may wish to back it up before you delete it.

    Otherwise, rakarrack does not have any per-user dependency.  I can only think that if one user can run rakarrack, and another cannot, is if permissions are different.

    You may also take the more "clean" approach and ls -l on the directory and included files to make sure the owner  permissions are "rw" (at least), and also that the current user is the owner.  Here are my permissions:
    ~$ ls .fltk/ -l
    total 8
    drwxr-xr-x 3 jakuleth jakuleth 4096 Feb 21  2012
    drwxr-xr-x 2 jakuleth jakuleth 4096 Mar  6  2012
    ~$ ls .fltk/ -l
    total 16
    -rw-r-r- 1 jakuleth jakuleth 16234 Nov 29 20:42 rakarrack.prefs

    (I am user "jakuleth")

    If the .fltk/ permissions are not the problem, then this is very strange indeed.  It would mean the user perhaps cannot access some system resource.

  • Transmogrifox

    Transmogrifox - 2012-12-18

    Something else occurred to me:  Does your primary user run any programs/services that use a lot of CPU resources?  Maybe rakarrack, trying to start with a high CPU preset, maybe overloads the CPU, but the other user is not using some CPU-hog application.

    Watch the CPU meter as you start rakarrack

  • Joel

    Joel - 2012-12-18

    Hi Josep,

    Thanks for your investigation and thinking…

    So I did the following:
    1) Actually a have the rakarrack version 6.1-2.5, which open Suse provides, running on my new account which is "music", but not running on my main account "joel".
    - If I run under my main account "joel" first qjackctl and start it, then I start rakarrack, I get an segmentation fault.
    - If I start rakarrack without starting qjackctl in advanced I got some jack messages and then unknown error (as in post #4.)
    2) In my new account I start first qjackctl start it, and then start rackarrak. It starts…

    3) I copied the whole .fltk folder from "music" into "joel". I changed owner and groupe owner and I gave it the permission 755 for the whole folder (so the user joel has write read and executable rights). try to start rakarrack with and without qjackctl in previous. Same errors.

    4) I removed the whole .fltk folder, tried again. No success

    Other tial:
    5) I uninstalled the open suse rakarrack build. And tried to remove all rakarrack files on my pc…
    6) I check out the git
    7) sed the two lines into rakarrack.cxx opened the file and checked if the two fonts line are really commented. It is
    8) Installed the whole thing again (, ./configuere, make, sudo make install)
    9) Checked under account music, if rakarrack is still working. (uff yes. ok)
    10) Checked in my main account if I can get it running. -> No change. Still the same errors.
    11) I checked if rakarrack created a new config file under joel/.fltk. -> No, but a new

    I think there must be something with fltk or with jack. But I think we waist a lot of time to figure out the issue.
    I will just play my guitare under the new account…

    Rakarrack is running but not in my main account. I think 95% is solved. To solve the last 5% I have to spend much more time… As usual with SW…

    So thanks Josep


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks