upload link grayed, php.ini settings correct

Help
jtc
2008-03-03
2013-05-17
  • jtc

    jtc - 2008-03-03

    i made sure my php.ini settings were correct (uploads on, uploads and post max sizes set), and permissions were correct (tried everything including 777) ... but the upload link is still grayed out. 

    any ideas?  i can create files and folders just fine, so it shouldn't be a write issue.  the upload size is set to 20 megs, the post size to 8 megs.

    thanks,
    j

     
    • jtc

      jtc - 2008-03-03

      this is probably a bad idea, but i went into the include file fun_list.php, found the UPLOAD section, and got rid of the if statement.  whatever the if is checking for, i made it not check for it ...

      if anyone can tell me what repercussions this would have, that would be great.

      thanks,
      j

       
      • Claudio Klingler

        I'm not sure which line you have removed from fun_list.php but i think this is an bad idea.

        Check this points to enable file uploading:

        - in your conf.php there must be an configuration entry:
           $GLOBALS["file_uploads"] = true;
        - enable user authentication to control who may upload files (also in your conf.php):
           $GLOBALS["require_login"] = true;
        - ensure the user is allowed to upload files to the (current) directory
        - check (as you did) write permissions on the directory for the webserver.

        Best regards,
        amadeus74

         
    • jtc

      jtc - 2008-03-04

      ah ok, that's the solution i think.  there is no $GLOBALS["file_uploads"]
      entry in conf.php.  on the other hand, the line i removed from the
      fun_list.php file was the if statement that checks for this variable ...
      did the same sort of thing, but obviously not as good a solution since
      it's hard-coding essentially.

      thanks!

       
    • hquadrat

      hquadrat - 2008-10-20

      Hi guys,

      the following news: I had the same 'upload does not work'-grayed out-issue for hours now and seems there is a little php thing the developers might wanna have an eye on. Here

      http://de2.php.net/manual/de/function.get-cfg-var.php#69390

      in the very last comment is the interesting fact! The function get_cfg_var only reads config-values already written to the php.ini - but as we set $GLOBALS["file_upload"] = true; in the conf.php-file it can not be read by the get_cfg_var function then of course.

      To correctly read the value, line 288 in fun_list.php hast to be changed to
      if(ini_get("file_uploads")) {
      ini_get can read the value of $GLOBALS["file_upload"] correctly (ini_get reads values set during runtime) and QuiXplorer will behave as we want it to.

      Little difference, big effect - it works now! This cost me hours and hours and hopefully saves time for others; bug has to be tested, confirmed and fixed by the developers of course.

      Regards,

      Henning

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks