#14 Ability to ignore version mismatch while opening qucs schematic

Unstable_(example)
closed
Frans
qucs (5)
5
2014-05-17
2014-01-11
No

What do you think about making choice to load or not to load qucs schemaatic if it has version mismatch? This feature may be Qucs advantage against commercial circuit simulators, that not allowes to load another document versions.

I add this experimantal ability. Now if you try to load schematic and it has another version, you can load it anyway or stop loading. Qucs now can offer load or not to load such documents.

See, please, Pull Request #30 at github.com

Discussion

  • Guilherme

    Guilherme - 2014-01-11

    Nice. Can it report to the user what is the mismatch?
    Typically Qucs doesn't like a newer version right? An installed version 0.0.17 complains if you try to open a 0.0.18 schematic... I believe it opens ok any older version.

    It will only work if you try to open a given schematic explicitly. If you have newer schematics inside a project directory they are no even listed in the dock.

    Shall we add an check box option on the settings to allow the opening of newer schematics? This will save the users from having to edit manually the version of the schematic.

    If this check box is market it will use your code above, plus reveal any schematic found on the project directory (to be coded). How does it sound?

    Thank you for your contributions. If I may suggest, please put any new feature you want to propose in a different pull request/patch. It makes it easier to review and discuss further if needed.

    Regards, .o/

     
  • Vadim Kuznetsov

    Vadim Kuznetsov - 2014-01-12

    Guilherme!

    Yes, version mismatch means, than we are trying to load schematic from future version.

    I try to add checkbox, which allows to load schematics from future versions in projects. See pull request #30 at github.com

     
  • Guilherme

    Guilherme - 2014-05-17
    • status: open --> closed
     

Log in to post a comment.