installation problem imac G5 PPC osx Tiger 10.4.11

Help
Sergio
2014-03-29
2014-04-21
<< < 1 2 (Page 2 of 2)
  • Sergio
    Sergio
    2014-04-13

    Hi Guilherme,
    Not followed Option 1, because I have to install Git (that probably needs x that check for y, and so on...)
    Not followed Option 2, because I do not understand what you mean
    I followed option n.3.
    I modified autogen.sh as written on [2]
    typed sh autogen.sh : ok
    not found CXX= or cc= inside configure.ac (where I have to write it?)
    typed ./configure --enable-maintainer --prefix=[install path]:ok
    make install.....
    errors, errors, errors
    after a lot of line, the final result is:

    collect2: ld returned 1 exit status
    make[2]: [qucs] Error 1
    make[1]:
    [install-recursive] Error 1
    make: *** [install-recursive] Error 1

    I stopped (no Qucs-core part done), I prefere to wait.
    Impossible to install Qucs on my computer.
    Goodnight.

     
  • Guilherme
    Guilherme
    2014-04-13

    Hi.

    The reference [2] shows the changes that you had to do manually do on
    qucs/configure.ac and qucs-core/configure.ac. After you change either of these files you need to run qucs/autogen.sh and qucs-core/bootstrap.sh before running configure.

    If you cannot do it, please download once again a new snapshot from the repository, this was option 2). Go to https://sourceforge.net/p/qucs/git/ci/master/tarball and download a zip file, remember?

    Just download a new snapshot, unzip and go from there.

    Probably the default compiler on your system is the old one. To use the newer gcc-4.6 you can do with the CXX and CC variables.

    Just download and unzip the new snapshot and execute each line like that:

    cd qucs
    sh autogen.sh
    CXX=g++-4.6 CC=gcc-4.6 ./configure --enable-maintainer-mode
    make
    make install
    

    If this works move on to qucs-core.

    If you want to install elsewhere you provide --prefix=/opt/local or --prefix=/Users/[YOURNAME]/local. It has to be somewhere in your system. If you leave the --prefix out it will install in /usr/local.

    It is not impossible, but if you never did it might take a bit of work and learning. I told you in the beginning...

    Regards,
    Guilherme

     
  • Sergio
    Sergio
    2014-04-14

    Hi,
    I downloaded the new zip file, extracted it.
    typed sh autogen.sh = ok
    typed CXX=g++-4.6 CC=gcc-4.6 ./configure --enable-maintainer-mode
    errors, below what terminal said:
    CXX=g++-4.6 CC=gcc-4.6 ./configure --enable-maintainer-mode
    checking build system type... powerpc-apple-darwin8.11.0
    checking host system type... powerpc-apple-darwin8.11.0
    checking target system type... powerpc-apple-darwin8.11.0
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... ./install-sh -c -d
    checking for gawk... no
    checking for mawk... no
    checking for nawk... no
    checking for awk... awk
    checking whether make sets $(MAKE)... yes
    checking whether make supports nested variables... yes
    checking whether to enable maintainer-specific portions of Makefiles... yes
    checking whether the C++ compiler works... no
    configure: error: in /Users/sergio/git/qucs/qucs': configure: error: C++ compiler cannot create executables Seeconfig.log' for more details

    attached config.log
    It seems that gcc installed on my computer is not 4.6
    But I'm sure that I installed it through macports, without errors...

    Goodnight.

     
    Attachments
  • Guilherme
    Guilherme
    2014-04-14

    You are right, the gcc 4.6 is not the default compiler, that is why you get this on the log:
    ./configure: line 1: g++-4.6: command not found

    Can you run like something like?
    /opt/local/bin/g++-4.6 --version

    If you can run this... you should be able tho run

    CXX=/opt/local/bin/g++-4.6 CC=/opt/local/bin/gcc-4.6 ./configure --enable-maintainer-mode

    You got the compiler installed, however it is not set as the default compiler, hence it is not found! The default compiler is probably gcc-4.2.

    With MacPorts there is way to change the default compiler. Maybe this helps [1].
    If you do this, you don't even have to do the CXX and CC stuff. The configure script will default to the new compiler.

    [1] http://stackoverflow.com/questions/8361002/how-to-use-the-gcc-installed-in-macports

     
  • Sergio
    Sergio
    2014-04-18

    Hi Guilherme,
    new the default compiler is 4.6.(using macports)
    I did:
    cd qucs
    sh autogen.sh = ok
    ./configure --enable-maintainer-mode = ok

    make = this warnings:
    ld: warning: object file compiled with -mlong-branch which is no longer needed. To remove this warning, recompile without -mlong-branch: /usr/lib/crt1.o
    ld: warning: object file compiled with -mlong-branch which is no longer needed. To remove this warning, recompile without -mlong-branch: /opt/local/lib/gcc46/gcc/ppc-apple-darwin8/4.6.4/crt3.o
    Making all in contrib
    make[2]: Nothing to be done for all'. make[2]: Nothing to be done forall-am'

    make install = these errors:

    Creating MacOSX applications...
    Copying and setting up MacOSX/Qt framework...
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucs.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucsattenuator.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucsfilter.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucshelp.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucslib.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucsedit.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    running: macdeployqt /User/sergio/local/qucs-auto/bin/qucstrans.app
    ERROR: no file at "/opt/local/lib/lib/libstdc++.6.dylib"
    ERROR: no file at "/opt/local/lib/lib/libgcc_s.1.dylib"
    make[2]: Nothing to be done for `install-data-am'.

    Now the Application start!!!

    After I tried to do the installation of Qucs Core:
    sh bootstrap.sh = ok
    ./configure --enable-maintainer-mode --prefix=/User/[username]/local/qucs-auto

    It gave to me this error:
    checking for flex version... configure: error: 2.5.4 < 2.5.9
    no possible to continue with installation.

    What do you think? Am I near the solution?
    Thanks!

     
  • Guilherme
    Guilherme
    2014-04-18

    Great you got the Qt apps to work!
    Just to inform others that will read this forum in the future, what is the command to change the default compiler? How long did it take to compile?

    Note that you have to put an existing path after `--prefix='

    You will need to update flex, can you port search flex ?
    Probably you will also need a newer bison (2.6+).
    Can you update these from MacPorts? Otherwise you will have to compile them from source... I can send you instructions.

     
  • Sergio
    Sergio
    2014-04-19

    Yes it works now, but with limitations.
    First I answer to you:
    Following your instructions:
    I installed gcc++4.6 from macports
    To change default compiler
    I typed:
    $ port select --list gcc
    It answers:
    Available versions for gcc:
    ....
    mp-gcc46
    ....
    I typed:
    $ sudo port select --set gcc mp-gcc46
    Password:
    It answers
    Selecting 'mp-gcc46' for 'gcc' succeeded. 'mp-gcc46' is now active
    I restarted terminal to become active.
    I compiled just Qucs (not yet Qucs Core), it takes more ore less 10-15 minutes.

    For my situation, what I have to do now?
    I suppose I have to install Qucs Core, but first I have to Update flex and bison, is it true?
    Watching on Macports web site, bison is available in 2.7.1 version(ok), but Flex is available in 2.5.37, it seems older than the necessary...

    Using Qucs, I designed my first simple circuit. It does not start the simulation (errors), could it depending on Qucs core not done, or on others errors?
    Wait for your instructions.
    Thanks

     
  • Guilherme
    Guilherme
    2014-04-20

    I forgot to mention, the errors you saw on make install for Qucs are not important. These are coming from macqtdeploy, trying to bundle the libraries...

    Yes, qucs-core is needed to run the simulations.

    Please install flex 2.5.37 from MacPorts. This should fix the previous error.
    Re-run ./configure --enable-maintainer-mode to make sure.

    Next, it will probably fail complaining about ADMS (Perl, LibXml or GD modules).

    Download this from my dropbox, soon it will be updated on the main repo: https://www.dropbox.com/s/73s9a88z1xltme5/adms-2.3.1_candidate.tar.gz

    tar xfvz adms-2.3.1_candidate.tar.gz 
    cd adms-2.3.0/
    ./configure
    sudo make install
    

    Please try admsXml and which admsXml to see if it is working, and find out its location.

    Then you should be set to compile qucs-core

    cd `qucs-core`
    sh bootstrap.sh
    ./configure --enable-maintainer-mode --with-mkadms=/usr/local/bin/admsXml
    sudo make install
    

    Note that you are passing the location of admsXml.

    I hope it will work this time...

     
    Last edit: Guilherme 2014-04-20
  • Sergio
    Sergio
    2014-04-21

    Hi Guilherme!
    I followed your instruction and now Qucs is completely installed!!!
    Thank you very much for your big, big, help!
    Great!
    Bye.
    Sergio

     
<< < 1 2 (Page 2 of 2)