#95 Optimization of Physical Lengths Erratic or Erroneous

0.0.17
closed
nobody
None
5
2013-06-20
2013-04-30
randyc
No

Something strange occurs when optimizing physical dimensions in some "transmission line" models, especially the first model in the transmission line menu.

Optimization satisfies all of the requirements specified BUT when the physical dimensions are applied to the appropriate variables the performance does not remotely resemble the optimization prediction.

An obvious question when assigning variables to transmission line physical lengths is the units of measure. Applying a unit of measure to a variable name (e.g. “L3 mil”) produces and error message. But without that assignment, how does QUCS understand that imperial units are to be used rather than metric ?

An example schematic indicates a detector diode with some microstrip matching elements and an optimization statement. If the line dimensions are allowed to be optimized then apparently all of the conditions are met and all is well. However if one then changes the physical dimensions to those that have been optimized and runs the simulation again the results are totally different.

The file “detector.sch” is the optimized circuit and observation of the Smith Chart output will immediately trigger alarm: NOTHING can be that perfect a match except an “ideal” 50 ohm resistor.

Assigning the optimized variables to their physical dimensions in the file “detector2.sch” and running the simulation produces a more reasonable display on the Smith Chart.

Based on a few trials, the problem is rather spotty to trace. Sometimes microstrip models converge properly but (as in the current case) sometimes they do not. Ditto with ideal transmission line elements.

1 Attachments

Related

Bugs: #95

Discussion

  • Frans

    Frans - 2013-05-28

    This bug has been discussed on the forum

     
  • Frans

    Frans - 2013-05-28
    • status: open --> closed
     
  • randyc

    randyc - 2013-05-28

    Can you please provide a reference to that discussion so that I can examine what others have said( and possible work-arounds) ?

    Thanks,
    randyc


    From: Frans fransschreuder@users.sf.net
    To: [qucs:bugs] 95@bugs.qucs.p.re.sf.net
    Sent: Tuesday, May 28, 2013 12:37 AM
    Subject: [qucs:bugs] #95 Optimization of Physical Lengths Erratic or Erroneous

    This bug has been discussed on the forum


    [bugs:#95] Optimization of Physical Lengths Erratic or Erroneous
    Status: closed
    Created: Tue Apr 30, 2013 04:33 PM UTC by randyc
    Last Updated: Tue Apr 30, 2013 04:33 PM UTC
    Owner: nobody
    Something strange occurs when optimizing physical dimensions in some "transmission line" models, especially the first model in the transmission line menu.
    Optimization satisfies all of the requirements specified BUT when the physical dimensions are applied to the appropriate variables the performance does not remotely resemble the optimization prediction.
    An obvious question when assigning variables to transmission line physical lengths is the units of measure. Applying a unit of measure to a variable name (e.g. “L3 mil”) produces and error message. But without that assignment, how does QUCS understand that imperial units are to be used rather than metric ?
    An example schematic indicates a detector diode with some microstrip matching elements and an optimization statement. If the line dimensions are allowed to be optimized then apparently all of the conditions are met and all is well. However if one then changes the physical dimensions to those that have been optimized and runs the simulation again the results are totally different.
    The file “detector.sch” is the optimized circuit and observation of the Smith Chart output will immediately trigger alarm: NOTHING can be that perfect a match except an “ideal” 50 ohm resistor.
    Assigning the optimized variables to their physical dimensions in the file “detector2.sch” and running the simulation produces a more reasonable display on the Smith Chart.
    Based on a few trials, the problem is rather spotty to trace. Sometimes microstrip models converge properly but (as in the current case) sometimes they do not. Ditto with ideal transmission line elements.


    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/qucs/bugs/95/
    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #95

  • randyc

    randyc - 2013-05-31

    Hi again - can you tell me where I can find the information to which you referred ?

    Thanks,
    Randy


    From: Frans fransschreuder@users.sf.net
    To: [qucs:bugs] 95@bugs.qucs.p.re.sf.net
    Sent: Tuesday, May 28, 2013 12:37 AM
    Subject: [qucs:bugs] #95 Optimization of Physical Lengths Erratic or Erroneous

    This bug has been discussed on the forum


    [bugs:#95] Optimization of Physical Lengths Erratic or Erroneous
    Status: closed
    Created: Tue Apr 30, 2013 04:33 PM UTC by randyc
    Last Updated: Tue Apr 30, 2013 04:33 PM UTC
    Owner: nobody
    Something strange occurs when optimizing physical dimensions in some "transmission line" models, especially the first model in the transmission line menu.
    Optimization satisfies all of the requirements specified BUT when the physical dimensions are applied to the appropriate variables the performance does not remotely resemble the optimization prediction.
    An obvious question when assigning variables to transmission line physical lengths is the units of measure. Applying a unit of measure to a variable name (e.g. “L3 mil”) produces and error message. But without that assignment, how does QUCS understand that imperial units are to be used rather than metric ?
    An example schematic indicates a detector diode with some microstrip matching elements and an optimization statement. If the line dimensions are allowed to be optimized then apparently all of the conditions are met and all is well. However if one then changes the physical dimensions to those that have been optimized and runs the simulation again the results are totally different.
    The file “detector.sch” is the optimized circuit and observation of the Smith Chart output will immediately trigger alarm: NOTHING can be that perfect a match except an “ideal” 50 ohm resistor.
    Assigning the optimized variables to their physical dimensions in the file “detector2.sch” and running the simulation produces a more reasonable display on the Smith Chart.
    Based on a few trials, the problem is rather spotty to trace. Sometimes microstrip models converge properly but (as in the current case) sometimes they do not. Ditto with ideal transmission line elements.


    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/qucs/bugs/95/
    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #95

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks