#140 Menu Tools > does not lauch tool app if prefix/bin not in PATH

0.0.18
closed-fixed
nobody
None
5
2014-06-10
2014-02-16
Guilherme
No

I guess it has to do with this commit:
48864d37ce8aa1526ddf6efa9463c847e42b766c removed q3process throughout the project

It looks for qucslib, qucsfilter,..., in the PATH.
It is unnecessary to ask users to append the installation path to the PATH.

I believe it should look into this order:
* install prefix, previously QucsSettings.BinDir + "qucsfilter"
* PATH
* File > App. Settings > Locations (TODO should enable user to point to the location of tools)

Discussion

  • Guilherme

    Guilherme - 2014-03-08

    It cannot find many things on the Tools menu (the Matching Circuit dialog belongs to Qucs).

    Temporary workaround:

    1) export PATH=$PATH:/path/to/qucs/bin
    2) Set the editor in: File > Application Settings > Settings > (put just qucsedit not a full path)

    It breaks if you do not install into a location on the path (bad decision). Further it will remember your text editor from previous sessions, possibly breaking if you test install to another prefix. In any case, the QMessageBoxes are not catching the failed start of the tools...

     
  • Guilherme

    Guilherme - 2014-03-16

    3) the env variable QUCSDIR also play a role here. $ export QUCSDIR=/somewhere/qucs

     
  • Guilherme

    Guilherme - 2014-06-10
    • status: open --> closed-fixed
     
  • Guilherme

    Guilherme - 2014-06-10

    fixed on master

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks