#153 Clan Arena mod "auto setinfo" problem

closed-out-of-date
nobody
None
5
2001-10-16
2000-12-31
Ray Hahn
No

I'd reported this before, and I believe that I later reported that it was fixed with beta5, but I that appears not to be the case. It is also happening with the "latest developer" version compiled on 12-30-2000.

Here's what happens:
1) Start Clan Arena on the server.
2) Attach as a player.
3) Select a team (i.e. hit 1 or 2 to select blue or red).

At this point Clan Arena will do some background stuff for you. It'll set your team to blue (or red, as the case may be), set bottomcolor and topcolor to your teams colors, and do a "setinfo oldteam blue" (or red). It appears that the QuakeForge code is not allowing that setinfo to work when it's first done on a server. The team and colors are set, but the "oldteam" setinfo information isn't set. In addition, every second the server sends to all the attached players the message: usage: setinfo [(key) (value) ]

Basically the mod doesn't run since no rounds can start with that happening.

There are 2 workarounds that seems to work OK. Have someone select a team and let the error messages start. Then either everyone must disconnect and reconnect, or everyone must do a "notready" command and then reselect teams. From then on it seems to run fine (or at least I think it does - it might start up again later for all I know).

I've got a screenshot of what is broadcast at http://www.bunsenlabs.com/quake/quakeforge/bugreport1/quake02.jpg

I also get an "unknown command: r_skyname" message when attaching to my server, but you probably already know about that.

Ray
Dr.Bunsen

Discussion

  • Ray Hahn

    Ray Hahn - 2000-12-31

    Sorry, it should be obvious, but just in case I should've mentioned that this is a problem with the server not with the client.

    Thanks!

    Ray
    Dr.Bunsen

     
  • Dabb

    Dabb - 2000-12-31

    Hm, looks pretty much like "alias" problem we were having long time ago. I'll try dig into this...

     
  • Dabb

    Dabb - 2000-12-31
    • assigned_to: nobody --> dabb
     
  • Nobody/Anonymous

    I couldn't reproduce this with latest binaries and clan arena v1.3 - everything worked without problems.

    Could you give me IP address of your server or some other server with that problem so I can do some testing? email: dabb@users.sourceforge.net

     
  • Bill Currie

    Bill Currie - 2001-01-07
    • status: open --> closed-invalid
     
  • Bill Currie

    Bill Currie - 2001-01-07
    • status: closed-invalid --> open
     
  • Bill Currie

    Bill Currie - 2001-01-07

    oops

     
  • Bill Currie

    Bill Currie - 2001-01-07

    Please determine whether this message is coming from the client or the server. While I HAVE found a potential source of this problem (see the bug link below), knowing where the message is coming from will help a lot. Using a packet sniffer is probably your best bet.

     
  • Ray Hahn

    Ray Hahn - 2001-01-08

    OK, I'll admit a "DOH!" of sorts. It's actually with ClanArena_D which is what most Clan Arena servers are nowadays. The original Clan Arena stopped with v1.3, but MC-Sam (a clanmate of mine in The Muppet Clan) came up with the idea of scoring via damage inflicted and continued on the ClanArena name. The first damage scoring version from MC-Sam was v1.4 and everyone (or, at least, every server that I've seen) is now running v1.5. I've got a copy of it available at http://www.bunsenlabs.com/games/qw/cad15.zip. I'll email it to dabb in just a moment.

    As to whether it's coming from the client or the server, I don't know and I don't have a packet sniffer available so I'm not sure how to help with this beyond making the mod available (above) for someone who does have a packet sniffer.

    Otherwise let me know how I can help with this. I could set up a private port for just you guys to jump onto if you like.

    Ray
    Dr. Bunsen

     
  • Dabb

    Dabb - 2001-06-09
    • assigned_to: dabb --> nobody
    • summary: Clan Arena mod "auto setinfo" problem --> Clan Arena mod "auto setinfo" problem
     
  • Bill Currie

    Bill Currie - 2001-10-16
    • status: open --> closed
     
  • Bill Currie

    Bill Currie - 2001-10-16
    • summary: Clan Arena mod "auto setinfo" problem --> Clan Arena mod "auto setinfo" problem
    • status: closed --> closed-out-of-date
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks