#103 [translations_lupdate] at make-install time

git_head
closed
nobody
2015-02-01
2014-05-08
No

Configure and make went great, but make install produced the deadly error seen at the end :

⚡ ./configure --enable-xunique

(...)

  Qtractor 0.6.0.6

  Build target . . . . . . . . . . . . . . . . . . .: release

  JACK Audio Connection Kit support  . . . . . . . .: yes
  ALSA MIDI Sequencer support  . . . . . . . . . . .: yes
  General audio file support (libsndfile)  . . . . .: yes
  Ogg Vorbis audio file support (libvorbis)  . . . .: yes
  MPEG-1 Audio Layer 3 file support (libmad) . . . .: no
  Sample-rate conversion support (libsamplerate) . .: yes
  Pitch-shifting support (librubberband) . . . . . .: yes
  OSC service support (liblo)  . . . . . . . . . . .: yes
  Archive/Zip file support (zlib)  . . . . . . . . .: yes
  IEEE 32bit float optimizations . . . . . . . . . .: yes
  SSE optimization support (x86) . . . . . . . . . .: yes
  LADSPA plug-in support . . . . . . . . . . . . . .: yes
  DSSI plug-in support . . . . . . . . . . . . . . .: yes
  VST plug-in support  . . . . . . . . . . . . . . .: yes
  LV2 plug-in support (liblilv)  . . . . . . . . . .: yes
  LV2 plug-in UI support (libsuil) . . . . . . . . .: yes
  LV2 plug-in External UI support  . . . . . . . . .: yes
  LV2 plug-in MIDI/Event support . . . . . . . . . .: yes
  LV2 plug-in MIDI/Atom support  . . . . . . . . . .: yes
  LV2 plug-in Worker/Schedule support  . . . . . . .: yes
  LV2 plug-in State support  . . . . . . . . . . . .: yes
  LV2 plug-in State Files support  . . . . . . . . .: yes
  LV2 plug-in Programs support . . . . . . . . . . .: yes
  LV2 plug-in Presets support  . . . . . . . . . . .: yes
  LV2 plug-in Time support . . . . . . . . . . . . .: yes
  LV2 plug-in Options support  . . . . . . . . . . .: yes
  LV2 plug-in Buf-size support . . . . . . . . . . .: yes

  JACK Session support . . . . . . . . . . . . . . .: yes
  JACK Latency support . . . . . . . . . . . . . . .: yes

  Non Session Management (NSM) support . . . . . . .: yes

  X11 Unique/Single instance . . . . . . . . . . . .: yes
  VeSTige header support . . . . . . . . . . . . . .: yes
  Gradient eye-candy . . . . . . . . . . . . . . . .: yes
  Debugger stack-trace (gdb) . . . . . . . . . . . .: no

  Install prefix . . . . . . . . . . . . . . . . . .: /usr/local

⚡ make
(...)
make[2]: Leaving directory `/home/px/src/qtractor/src'
make[1]: Leaving directory `/home/px/src/qtractor'

⚡ sudo make install
lupdate: could not exec '/usr/lib/i386-linux-gnu/qt5/bin/lupdate': No such file or directory
make: *** [translations_lupdate] Error 1

⚡ uname -a                    
Linux moe 3.11.0-20-lowlatency #14-Ubuntu SMP PREEMPT Tue Apr 8 04:36:55 UTC 2014 i686 i686 i686 GNU/Linux

Discussion

  • Rui Nuno Capela

    Rui Nuno Capela - 2014-05-08

    you need to install lupdate to apply the translations (i18n)

    maybe that comes as a separate qt5 tools package for your distro.

    anyway, building to qt5 is not really recommended still. qt4 is the current stable target, so much for lv2 gui interoperability.

    byee

     
  • Yassin Philip

    Yassin Philip - 2014-05-08

    OK, sudo apt-get install qttools5-dev-tools solved it. But I fail to see how I can build to a specific QT version..? Incidentally, the "about QT" dialog says "This program uses Qt version 4.8.4." And I still can't see Sorcer controls (https://github.com/harryhaaren/openAV-Sorcer/issues/6). I'd still like to try QT5 :)

    Anyway, this ticket can be closed, sorry about this installation glitch.

     
  • Rui Nuno Capela

    Rui Nuno Capela - 2014-05-10
    • status: open --> closed
     

Log in to post a comment.