#167 Linux compile fails on V 2.4.1 source -- missing include

Luminance_HDR_2.3.0
open
nobody
None
1
2013-08-13
2013-08-13
Bob Tinker
No

On a ubuntu 10.04 system with gcc 4.4.3, compile failed at:
"src/Libpfs/io/pfsreader.cpp:88: error: ‘memcmp’ was not declared in this scope" and follow on errors indicating that the string.h include file was not loaded. Reading over the source, it looks like it should be loaded and referenced but something is missing. I couldn't discover exactly where the "-I/usr/include" token should go since cmake obfusticates what is actually going on. I must admin that I am not well versed in cmake. Attached is the make log file attached.

1 Attachments

Discussion


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks