Zaurus SL-5500, OZ 3.5.2, Holux-GM-270

GPS units
2005-06-17
2013-04-17
  • Nobody/Anonymous

    I'm trying to get GPS working on my Zaurus SL5500, with OpenZaurus 3.5.2 and my Holux-GM-270 CF card.

    I initially tried the qpegps off the sourceforge site ,and it segment faulted, even with the compatible libraries.

    I tried the qpegps compiled for OZ 3.5.2 on the OZ feed, and that ran okay.

    However, the gpsd compiled with OZ, while it ran, was not detected by qpegps, but the diagnosis mode showed that the longitude and latitude the cf card was giving out correctly.

    Then I tried the gpsd from sourceforge in the qpegps download section and it worked! I had the correct timestamp, all the green buttons lit up. But then I saw the longitute and latitude, and they about 2.5x what the should be, so apparently I was out somewhere swimming in the mid Atlantic.

    When in running the gpsd with -D5 mode the longitude and latitude match up with whats qpegps, but he figures are completely wrong. With the othe gpsd in -D5 mode it shows the correct gps co-ordinates but qpegps doesn't detect the daemon running.

    I've also tried the gpsd compiled for OZ 3.5.3, but that doesn't appear to detect properly either.

    Any ideas?

     
    • Arnim Läuger

      Arnim Läuger - 2005-06-29

      Guess you encounter the same problem I had with gpsd on OZ 3.5.3. The gpsd ipkg from the feed does not work with qpeGPS and the gpsd_from_qpegps_0_9_1 generates ridiculous coordinates.

      The latter problem is due to the fact that the newer OZ distributions switched to software floating point support rather than hardware floating point. Soft-float is said to be faster than hard-float but the drawback is that these concepts cannot be mixed. I.e. all your applications must be compiled with gcc's -msoft-float option in case they are targetted for a system with software floating point support. Otherwise, floating point results are not consistently shared between the application and the system libraries.

      In any case, here you will find a binary of gpsd_from_qpegps_0_9_1 compiled for OZ 3.5.3 with soft-float support:

        http://home.knuut.de/arnim.laeuger/gpsd_from_qpegps_0_9_1

      It works perfectly on my SL-5500 with OZ 3.5.3 interfacing a GM-270 to qpeGPS.

      Best regards

        Arnim

       
    • Nobody/Anonymous

      Fantastic! It worked straight away. You're a star.

       

Log in to post a comment.