new qpegps version 0.9.2.3

Maps
Voblin
2005-03-16
2013-04-17
  • Voblin

    Voblin - 2005-03-16

    Whats new in 0.9.2.3:
    1. minor bug fixes
    2. In menu which is available by <OK> button now added two items first: Switch view (full screen or normal)  second: Switch mode (GPS or Map)
    3. In GPS mode now you also can click to any point on the map and you will see dialog with point position (coordinates) and distance from current position to the pointed point, also in this dialog you can save pointed position in places.txt file (by pressing "Save" button) or Set up pointed position as destination (by pressing "Destination" button).
    4. You can switch between full screen and normal view by pressing <Cancel> / <Esc> button

     
    • Nobody/Anonymous

      It is not working on openzaurus 3.5.2 ...

       
      • Nobody/Anonymous

        Qpegps on OpenZaurus (my sl-5500)

        You Must install wget*.ipk package from the feed.
        The wget installed by default (busybox) lack parameters. (See console downmap results)

         
    • Nobody/Anonymous

      qpegps looks great; I have it running with Leadtek 9534 on Zaurus C750.  Problem downloading maps from mapblast:
      "Download ERROR.
      If you use proxy, Run Console "export http_proxy=http://myproxy:8080..."
      Tried, failed.  Am connected to network, Netfront browser works.  Suggestions?
      Thanks,
      George Almasi

       
    • Voblin

      Voblin - 2005-06-07

      1. You must type your proxy addres inctead of "myproxy".
      2. You must start qpegps also from this console by printing "qpegps" .

      I hop you do it.

      But I dont't know how to help you. I never use mapblast.
      Expedia looks better. use downloading maps from expedia.

       
    • Nobody/Anonymous

      I've the same problem, when i try to download a map from expedia i receive a download error, but my wifi connection works well...so what is the problem ???

       
    • Nobody/Anonymous

      <OK> button doesent' work on Zaurus SL-6000

       
    • Nobody/Anonymous

      ON Z SL6000 standard sharp rom "download a map from expedia" doesent' work.....

      - I execute qpegps as user and it gives me the error....
      - I execute qpegps as root...in this way my zaurus hungs after i push OK to start downloading....

       
    • Nobody/Anonymous

      I have the same problem on SL-6000.
      It's look like that qpegps require lot of free memory for downloading from expedia.
      I free some memory and it's start to work (remove some residentioal programs - uncheck "Fast load" from PIM's).
      Also I use downmap utility from console.

       
    • Voblin

      Voblin - 2005-06-14

      I haven't any experience with SL6000 or OZ.
      I haven't access to such devices.
      So, only some general recommendations

      1. Qpegps uses "downmap" utility to download. Downmap use "wget" to download. So it can spend lot of memory.
      2. Try download to another directory. Default catalog may be read-only on some OS. Also you can change access rights to default catalog and maps.txt file in it.
      3. Please try to use downmap from console with the same parameters. Use donmap -h for help.
      4. If It will not help try to check is wget really work? Enter command in console utility:
        wget -v -d -nd -t 7 -O test.gif "http://www.expedia.com/pub/agent.dll?qscr=mrdt&ID=3XNsF.&CenP=55.752389,37.618223&Lang=WLD0409&Alti=150&Size=656,532&Offs=0.000000,0.000000"

        and then see to test.gif file

      Inform me about results. As many information as available.

       
    • Nobody/Anonymous

      you need to grab "getmap" then it'll work fine on the 6000L (which is what I did to get it to work properly)

       
    • Nobody/Anonymous

      how to install it ?

       
    • Nobody/Anonymous

      Looks like the problem is that by default the /home/QtPalmtop/qpegps directory, and all the files and directories in it, are only writeable by 'root'.  Not knowing how .ipk files are setup, it would seem there is a step missing to allow the 'zaurus' account write access.

       
    • Nobody/Anonymous

      I have qpegps working well on my PMA400, thanks for your efforts, they are appreciated :D

      I have a couple of issues with the PMA and its screen size.

      The download maps form extends below the bottom of the viewable area, could this be condensed a little?

      Also the same issue when setting/deleting a destination, the longitude is not visible at all.

      Also when downloading maps of any scale from mulitimap for the UK, they are all not centred correctly.

      Keep up the good work.

      Kev

       
    • Nobody/Anonymous

      everything worked perfect on my zaurus 5500. just make sure you're using the old gpsd. (the binary is called "gpsd_from_qpegps_0_9_1_compiled_with_soft-float_support
      " and can be found in the download section of this page. chmod 777 that file and copy it to the /bin directory. there you go... i'm using downmap on a ubuntu-system and it goes flawless.. thnx

       
    • Graham

      Graham - 2006-10-27

      Since there hasn't been much apparent movement on qpegps development I have been looking at integrating gpsd 2.3X with the 0.9.2.3.3 code (also noted here: http://www.oesf.org/forums/index.php?showtopic=21834\).

      Has anybody else done this already and not reported it? and are many people that interested?

       
    • Nenad Bulatović

      It doesn't run on my iPAQ 3970/Familiar 0.8.4/Opie 1.2.1 :(
      I'm getting weird symbol error in QtColor::DarkCyan

       
      • ztep

        ztep - 2007-01-23

        > I'm getting weird symbol error in QtColor::DarkCyan

        It is defined on qnamespace.h, that is part of qt 2.3. Please test for that file

         
      • Nobody/Anonymous

        Hi all,

        V 0.9.2.3.3 works on my Archos PMA400.
        But V 0.9.3 terminates with code SIGSEGV.
        Searching the forum showed me that this bug was fixed with V 9.1.1 - but now it's back?

                   Ingo

         

Log in to post a comment.