QMC2 hanging on determining emulator version

  • Shane

    Shane - 2009-02-27

    Hi Rene -

    Recently I tried starting QMC2 on my computer but when the QMC2 application window pops up the program hangs and the frontend log just says 'determining emulator version and supported games.' QMC2 was working great just a couple weeks ago but now every time I start it this situation occurs.

    I am running QMC2 0.2b6, SDLMAME 0.129, and Gentoo x86_64 with QT 4.50_rc1. I did test QMC2 with QT 4.4.2 and I tested the svn build of QMC2 and the same thing occurs. I am completely stumped on what is causing this and why my emulator version cannot be determined. Thanks.


    • R. Reucher

      R. Reucher - 2009-02-28

      Yeah, that's a known issue of 0.2.b6 (and less), which doesn't happen always, but I've had those hangs as well... I fixed it in 0.2.b7 (SVN) - at least I hope so. For me, it doesn't occur any more. So please try the latest version from the SVN repository.

      From the change log:

      - imp: avoid potential locking during the determination of the emulator's version & supported games/machines due to a probably failed reception of the sub-process' finished() signal


      HTH, René

    • Shane

      Shane - 2009-02-28

      I just compiled, installed, and tested QMC2 0.2.b7 (SVN) and I am still getting the error :(.


      • R. Reucher

        R. Reucher - 2009-02-28

        Hmmm, then it's most likely something different... but I doubt it's a new bug of QMC2. It runs nicely on all the systems I've tested it on, but I must admit that I've never tried Gentoo myself. Anyway, I've not received any reports of this type yet.

        Could you please tell me what the results of these commands are (don't post them here, just let me know if they work as expected):

        $ mame -listfull '*'
        $ mame -help

        These commands are used to determine the MAME version and the number of supported games, so if they produce no valid data this may be the reason why...

        Did you install SDLMAME 0.129 from a precompiled binary package or did you build it yourself?

    • Nobody/Anonymous

      Hey Rene -

      I tested out the commands you mentioned and on Gentoo. The binary executable of mame is not called 'mame' but sdlmame. The I executed sdlmame -listfull and sdlmame -help both outputed information as expected. I did compile sdlmame from source when I installed 0.129 from the portage tree.

      I really do not understand why this is happening but one odd think is that every time I try to start qmc2 it says "it appears another instance of qmc2 is already running..." But I have killed the task and cannot find it running on the system. Thanks for all you help.


    • Shane

      Shane - 2009-03-01

      So I solved the problem but I don't know how to interpret the solution. I have two video cards installed in my computer, an integrated nvidia 6100 and an ATI PCI Express X1300.

      I recently switched over to the radeonhd driver to user my X1300 but I wanted to get some higher performance on a couple of games so I switched back to the proprietary nvidia drivers. This is when programs stopped function properly including QMC2 and Mozilla Thunderbird. So I switched back to my ATI card using the radeonhd driver and now everything works beautifully once again.

      This is just weird and I do not know why the nvidia driver would cause application abnormalities. It would be interesting to hear anyone's thoughts or theories.


    • R. Reucher

      R. Reucher - 2009-03-01

      Well, I'm glad to hear it was not related to QMC2 at least... anyway, it's still weird, that's true.

      Running the ATI driver (open source) AND the nVidia driver (proprietary) in parallel has caused troubles for me as well in the past, but of different type. I've even had to patch the drivers for a Linux thin client OS (ThinStation) to support a dual headed configuration for a client virtualization project at a customer (the one head needed to be rotated by 90° which was only possible with the proprietary nVidia driver without losing hardware acceleration at that time). Anyway, my problem was that it didn't work _at all_ in the first place...

      But you are using either one or the other, right? This should really just simply work... I'm stumped as well, but what should I say? I have an older Toshiba notebook with a "nVidia Corporation NV34M [GeForce FX Go5200 64M]" chipset. This old chipset is only supported by some beta-driver for my Linux distribution (openSUSE 11.1) and not by the newest drivers from nVidia. But there's no second graphics chipset involved...


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks