qdvdauthor 2.0.0 compile fails on Mandriva

Help
Chris
2009-10-14
2013-05-20
  • Chris

    Chris - 2009-10-14

    Have tried to compile qdvdauthor 2.0.0 on Mandriva 2009.1 - it fails.  Same system compiles qdvdauthor 1.11.1

    I've seen the bug report 2877042 in the Tracker.  I've tried the suggested fixes there and neither copying over the missing CONFIG.h from v 1.11.1 or using "./configure -n"  provide a workaraound.  It always fails, even tried renaming the directory - no good.

     
  • Varol Okan

    Varol Okan - 2009-10-14

    CONFIG should get re-created through ./configure.sh -n

    I am currently DL Mandriva and check it out.

    In the meantime can you please send me the output of the compilation

    Thx,

    Varol :)

     
  • Chris

    Chris - 2009-10-15

    There is no configure.sh file I assume you meant ./configure -n 

    To be fair that may well produce a CONFIG.h, it is using the graphical configurator that compalins about missing CONFIG.h   i.e ./configure -c

    Will stick with your suggested ./configure -n

    There seems to be problems with bzip2 at the end - but that is installed here:

    $ rpm -qf /usr/share/doc/libbzip2-devel

    libbzip2-devel-1.0.5-5mdv2009.1

    $ rpm -qf /usr/share/doc/libbzip2_1

    libbzip2_1-1.0.5-5mdv2009.1

    I can't see anyway to attach a file of the compilation output, and there are too many lines of output to put inline here. (Strange I'd have sworn it was possible to attach files).  So the beginning and end of the compilation will have to do for now…

        $ ./configure -n                                       
        configured with XINE_SUPPORT=1  MPLAYER_SUPPORT=1 VLC_SUPPORT=0 QTDIR3=/usr/lib/qt3 QTDIR4=/usr/lib/qt4 QT_LIB=                                                                                        
       
        *+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+**+*+*+*+*+*+*+*
        *+*+                                                +*+*
        *+*+   Please wait while building 'Q' DVD-Author    +*+*
        *+*+                                                +*+*
        *+*+ qdvdauthor qrender plugins qplayer             +*+*
        *+*+ libjhead ffmpeg                                +*+*
        *+*+                                                +*+*
        *+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+**+*+*+*+*+*+*+*
       
        Project MESSAGE: Build with Xine Support at : /usr/bin/xine-config
        Project MESSAGE: Build with MPlayer support                      
        /usr/lib/qt3/bin/uic qplayer/engines/dialogqxinesetup.ui -o .ui/dialogqxinesetup.h
        /usr/lib/qt3/bin/uic qplayer/engines/uidialogmplayersetup.ui -o .ui/uidialogmplayersetup.h
        /usr/lib/qt3/bin/uic formmain.ui -o .ui/formmain.h                                       
        /usr/lib/qt3/bin/uic qplayer/uistartstopcontrol.ui -o .ui/uistartstopcontrol.h           
        /usr/lib/qt3/bin/uic uidialogsubtitle.ui -o .ui/uidialogsubtitle.h                       
        /usr/lib/qt3/bin/uic uitemptab.ui -o .ui/uitemptab.h                                     
        /usr/lib/qt3/bin/uic uidvdlayout.ui -o .ui/uidvdlayout.h                                 
        /usr/lib/qt3/bin/uic uipreviewer.ui -o .ui/uipreviewer.h                                 
        /usr/lib/qt3/bin/uic uisubtitles.ui -o .ui/uisubtitles.h                                 
        /usr/lib/qt3/bin/uic uinewwizard.ui -o .ui/uinewwizard.h                                 
        /usr/lib/qt3/bin/uic uislideshow.ui -o .ui/uislideshow.h                                 
        /usr/lib/qt3/bin/uic uidialogfont.ui -o .ui/uidialogfont.h                               
        /usr/lib/qt3/bin/uic dialogmatrix.ui -o .ui/dialogmatrix.h                               
        /usr/lib/qt3/bin/uic dialogresize.ui -o .ui/dialogresize.h                               
        /usr/lib/qt3/bin/uic uidialogfiles.ui -o .ui/uidialogfiles.h                             
        /usr/lib/qt3/bin/uic uidialogimage.ui -o .ui/uidialogimage.h                             
        /usr/lib/qt3/bin/uic uidialogmovie.ui -o .ui/uidialogmovie.h                             
        /usr/lib/qt3/bin/uic uidialogabout.ui -o .ui/uidialogabout.h                             
        /usr/lib/qt3/bin/uic uidialogsetup.ui -o .ui/uidialogsetup.h                             
        /usr/lib/qt3/bin/uic uidialogframe.ui -o .ui/uidialogframe.h                             
        /usr/lib/qt3/bin/uic uidialogaudio.ui -o .ui/uidialogaudio.h                             
        /usr/lib/qt3/bin/uic uidialogalign.ui -o .ui/uidialogalign.h                             
        /usr/lib/qt3/bin/uic uidialogdelta.ui -o .ui/uidialogdelta.h                             
        /usr/lib/qt3/bin/uic uidialogregion.ui -o .ui/uidialogregion.h                           
        /usr/lib/qt3/bin/uic uidialogshadow.ui -o .ui/uidialogshadow.h                           
        /usr/lib/qt3/bin/uic dialoggeometry.ui -o .ui/dialoggeometry.h                           
        /usr/lib/qt3/bin/uic uidialogbutton.ui -o .ui/uidialogbutton.h                           
        /usr/lib/qt3/bin/uic uisourcewidget.ui -o .ui/uisourcewidget.h                           
        /usr/lib/qt3/bin/uic uidialogselect.ui -o .ui/uidialogselect.h                           
        /usr/lib/qt3/bin/uic uiprintpreview.ui -o .ui/uiprintpreview.h                           
        /usr/lib/qt3/bin/uic uidialogvfolder.ui -o .ui/uidialogvfolder.h                         
        /usr/lib/qt3/bin/uic uidialoglibrary.ui -o .ui/uidialoglibrary.h                         
        /usr/lib/qt3/bin/uic uicommandeditor.ui -o .ui/uicommandeditor.h                         
        /usr/lib/qt3/bin/uic uidialogconvert.ui -o .ui/uidialogconvert.h                         
        /usr/lib/qt3/bin/uic uidialogoverlay.ui -o .ui/uidialogoverlay.h                         
        /usr/lib/qt3/bin/uic uioneclickwizard.ui -o .ui/uioneclickwizard.h                       
        /usr/lib/qt3/bin/uic uicreatetemplate.ui -o .ui/uicreatetemplate.h                       
        /usr/lib/qt3/bin/uic uidialogtextfont.ui -o .ui/uidialogtextfont.h                       
        /usr/lib/qt3/bin/uic uitemplatewizard.ui -o .ui/uitemplatewizard.h                       
        /usr/lib/qt3/bin/uic uidialogthumbnail.ui -o .ui/uidialogthumbnail.h                     
        /usr/lib/qt3/bin/uic uidialoganimation.ui -o .ui/uidialoganimation.h                     
        /usr/lib/qt3/bin/uic uidialogmediainfo.ui -o .ui/uidialogmediainfo.h                     
        /usr/lib/qt3/bin/uic uitemplatedownload.ui -o .ui/uitemplatedownload.h                   
        /usr/lib/qt3/bin/uic uidialogextraction.ui -o .ui/uidialogextraction.h                   
        /usr/lib/qt3/bin/uic uidialogbuttontrans.ui -o .ui/uidialogbuttontrans.h                 
        /usr/lib/qt3/bin/uic uidialogrenderpreview.ui -o .ui/uidialogrenderpreview.h             
        /usr/lib/qt3/bin/uic plugins/menuslide/uimenuslide.ui -o .ui/uimenuslide.h               
        g++ -c -pipe -Wall -W -Wno-non-virtual-dtor -g -O0 -ggdb3 -D_REENTRANT  -DQDVD_LINUX -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_NO_DEBUG -I/usr/lib/qt3/mkspecs/default -I. -I/usr/lib/qt3/include -I.ui/ -Iqplayer/engines -I. -Iqplayer -Iplugins/menuslide -I.moc/ -o .obj/main.o main.cpp                    
        In file included from ../addons/jhead/libjhead/interface.h:18,                                     
                         from cachethumbs.h:81,                                                            
                         from main.cpp:30:
        /usr/lib/qt3/include/qimage.h: In member function ‘bool QImageTextKeyLang::operator<(const QImageTextKeyLang&) const’:                                                                                 
        /usr/lib/qt3/include/qimage.h:61: warning: suggest parentheses around && within ||                 
        g++ -c -pipe -Wall -W -Wno-non-virtual-dtor -g -O0 -ggdb3 -D_REENTRANT  -DQDVD_LINUX -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_NO_DEBUG -I/usr/lib/qt3/mkspecs/default -I. -I/usr/lib/qt3/include -I.ui/ -Iqplayer/engines -I. -Iqplayer -Iplugins/menuslide -I.moc/ -o .obj/log.o log.cpp                      

    **SNIPPED**

        g++ -Wl,-as-needed -Wl,-no-undefined -Wl,-z,relro -o ../bin/qrender .obj/main.o .obj/utils.o .obj/server.o .obj/render.o .obj/parser.o .obj/logger.o .obj/filter.o .obj/slideshow.o .obj/encoder.o .obj/ffmpeg_enc.o .obj/xml_slideshow.o .obj/moc_server.o .obj/moc_render.o    -L/usr/lib /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libavformat.a /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libavcodec.a /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libavutil.a /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libavdevice.a /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libswscale.a -L/home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib /usr/lib/libvorbisenc.so.2 -lQtXml -L/usr/lib -pthread -pthread -lQtGui -pthread -lpng -lfreetype -lgobject-2.0 -lSM -lICE -pthread -pthread -lXrender -lfontconfig -lXext -lX11 -lQtNetwork -pthread -pthread -lQtCore -lz -lm -pthread -lgthread-2.0 -lrt -lglib-2.0 -ldl -lpthread
        /usr/bin/ld: Dwarf Error: Offset (10746) greater than or equal to .debug_str size (2988).
        /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/lib/libavformat.a(matroskadec.o): In function `matroska_decode_buffer':
        /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/libavformat/matroskadec.c:919: undefined reference to `BZ2_bzDecompressInit'
        /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/libavformat/matroskadec.c:928: undefined reference to `BZ2_bzDecompress'
        /home/test/Download/qdvdauthor-2.0.0/qrender/ffmpeg/libavformat/matroskadec.c:931: undefined reference to `BZ2_bzDecompressEnd'
        collect2: ld returned 1 exit status
        make: ***  Error 1
        Start : Thu Oct 15 11:25:11 BST 2009
        End   : Thu Oct 15 11:50:57 BST 2009

     
  • Chris

    Chris - 2009-11-07

    Solved. Clean install of Mandriva 2010.0 and qdvdauthor 2.0.0 compiled successfully.

    Note tried
    ./configure
    which failed due to missing CONFIG.h as above.

    Followed this with
    ./configure -n

    This worked.

    Then to install:  su and
    ./configure -n -wget-buttons-library -install

     
  • Varol Okan

    Varol Okan - 2009-12-27

    Interesting,

    the linking issue is due to the missing -lbz2 during the linking stage.

    This an be checked by looking at the output of

    > /sbin/ldconfig -p | grep -m 1 libbz2.so | awk '{print $4}' | sort
    which should bring up something like
    /lib/libbz2.so.1
    If this is not the case then a
    > sudo /sbin/ldconfig

    I am currently in the process of fixing the first issue with the missing CONFIG.h file.
    Thank you for pointing this one out.

    Varol :)

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks