#2 race condition when using 2 cameras simultaneously

closed-invalid
None
6
2006-05-07
2005-01-14
No

I'm using qc-usb-0.6.2 on
Linux linux 2.6.8-24.10-default #1 Wed Dec 22 11:54:27
UTC 2004 i686 i686 i386 GNU/Linux.

I have 2 logitech quickcam notebook webcams connected.
Driver works fine when accessing each of them, but when
I try to use both of them simultaneously, I get race
condition (scrambled buffers, image of the second cam
appers as part of the first cam's image, etc...).

[This is not a bug of my own application, it happens
also using 2 xawtv tasks.]

Discussion

  • Holger Friedrich

    • summary: racen condition when using 2 cameras simultaneously --> race condition when using 2 cameras simultaneously
     
  • Holger Friedrich

    • priority: 5 --> 6
     
  • Holger Friedrich

    • status: open --> open-invalid
     
  • Holger Friedrich

    Logged In: YES
    user_id=595959

    bug is caused by bandwidth issues.
    2 cameras connected to different usb hubs on the main board
    seem to work perfectly.

     
  • Holger Friedrich

    Logged In: YES
    user_id=595959

    bug is caused by bandwidth issues.
    2 cameras connected to different usb hubs on the main board
    seem to work perfectly.

     
  • Kurt Wall

    Kurt Wall - 2006-05-07
    • assigned_to: nobody --> krwall
     
  • Kurt Wall

    Kurt Wall - 2006-05-07
    • status: open-invalid --> closed-invalid
     
  • Kurt Wall

    Kurt Wall - 2006-05-07

    Logged In: YES
    user_id=1507273

    Closing this because the "work-around" is The Right Thing To
    Do with high-bandwidth USB devices.

     

Log in to post a comment.