Thanks guys, I found a compatible version of PyX :D