Well, I downloaded it from the sourceforge link on libusb.org which is apparently no longer maintained.  So I've gotten the one 1.0.18 from sourceforge, and recompiled pyusb, but with the same result.  Of course, I've discovered that it works as root.  I'm more familiar with udev rules on linux, what is the mac equivalent?  And yes, I'm trying to use the system python.

On Fri, Mar 14, 2014 at 7:27 PM, Xiaofan Chen <xiaofanc@gmail.com> wrote:
On Sat, Mar 15, 2014 at 6:41 AM, Jen Evans <jwe080@gmail.com> wrote:
> Hi,
> I'm getting the no backend detected error (well it did work once but I
> couldn't get it work again).  This is on Mavericks 10.9.2, libusb-1.0.9, and
> pyusb-1.0.b.1. There weren't any obvious install errors. I tried export
> PYUSB_DEBUG_LEVEL=debug, but it only seems to output more after calling
> usb.core.find() a second time?  (and nothing extra from the command line
> even setting the file output) Output is below.  Listing devices using the
> libusb example works fine so I think that's installed right.  Any ideas?

How did you install libusb-1.0.9? BTW, the latest version of libusb
is 1.0.18.

I can use pyusb under Mac OS X 10.9.2 Maverick, but I am
not using the Python from system, I use Homebrew and install
Python and libusb from Homebrew.


Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
pyusb-users mailing list