#58 Unable to install pyserial 2.6 for python 3.3

closed
nobody
None
5
2013-01-17
2013-01-12
woobagooba
No

AFAIK I am following the install instructions to the letter.

It looks like the 2 to 3 conversion is not happening.

Help? Please see attached.

Discussion

  • woobagooba

    woobagooba - 2013-01-15

    BTW I need to use python 3.3 as I also need to use the 3.3 SocketCAN support.

     
  • woobagooba

    woobagooba - 2013-01-15

    I was able to repair the install by manually running 2to3 on the pyserial files.

    The pyserial install does indeed seem broken for python 3.3

     
  • woobagooba

    woobagooba - 2013-01-17

    I wiped the machine of any trace of python 2.7, python 3,3, and pyserial 2.6. Started over, downloaded and installed just python 3.3 and pyserial 2.6. All seems to be working now. No idea what caused the original problem.

     
  • woobagooba

    woobagooba - 2013-01-17
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks