Pypar MPI problems

  • karthik

    karthik - 2007-09-17

    Hi All,

    I am trying to install pypar on a Beowulf Cluster of 3 machines. I downloaded the latest alpha version of pypar. I have mpich running on the cluster. The installation succeeded, but when i run the program, I get send/recv errors.

    p1_22773: (0.007812) net_recv failed for fd = 3
    p0_22762: (2.890625) net_recv failed for fd = 7
    p0_22762:  p4_error: net_recv read, errno = : 104
    p1_22773:  p4_error: net_recv read, errno = : 9
    p0_22762: (4.898438) net_send: could not write to fd=6, errno = 32

    I know that the communication between the nodes is good and all the configurations are right, because, when i run a simple C program with MPI_Send and MPI_Recv, it works perfectly fine, without any of these errors.

    I would really appreciate it if someone could please tell me what could be going wrong here.



    • Ole Nielsen

      Ole Nielsen - 2007-11-13

      What happens when you run the test suite:


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks