#154 Forced download/install of ctypes with PyOpenGL-3.0.0a5

v3.0.0
closed-fixed
install (16)
5
2007-01-07
2006-11-25
lgautier
No

When installing PyOpenGL-3.0.0a5 from source against a Python-2.4 install,
downloading and installing ctypes seems to be forced
(although unnecessary in the case ctypes is already installed).

This is apparently coming from setup.py:
if sys.hexversion < 0x2050000:
requirements.append( 'ctypes' )

(and could be fixed by having a try/except
around an 'import ctypes' to check for an available
ctypes for example).

Discussion

  • Mike C. Fletcher

    Logged In: YES
    user_id=34901
    Originator: NO

    Agreed. Adapted in CVS.

     
  • Mike C. Fletcher

    • assigned_to: nobody --> mcfletch
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks