On 16 Nov, 2012, at 10:48, Kunal Parmar <kunalparmar@gmail.com> wrote:

I've been having this problem where an app built with py2app does not run correctly when I double click it from Finder. It works if I run the executable directly (.app/Contents/MacOS/app) from Finder or via terminal.

I tried troubleshooting but only got so far as to know that applicationDidFinishLaunch: is not getting called on my app delegate. I dont know why though.

You migth depend on details of the shell environment. 

What do you mean by "does not run correctly"? Does the application launch but with limited functionality, or do you get an error when launching? 

Do the basic examples that are included with pyobjc work?

Ronald



I found a couple other threads talking about the same problem - 
http://stackoverflow.com/questions/11663545/launching-application-made-with-py2app
https://groups.google.com/forum/#!topic/pygame-mirror-on-google-groups/eBEW8m0jtl0

I'm using py2app v0.7.1, pyobjc-core v2.4 on OS X 10.8.2.

Hope someone here can help!

Thanks,
Kunal
------------------------------------------------------------------------------
Monitor your physical, virtual and cloud infrastructure from a single
web console. Get in-depth insight into apps, servers, databases, vmware,
SAP, cloud infrastructure, etc. Download 30-day Free Trial.
Pricing starts from $795 for 25 servers or applications!
http://p.sf.net/sfu/zoho_dev2dev_nov_______________________________________________
Pyobjc-dev mailing list
Pyobjc-dev@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/pyobjc-dev