Ben,

use pyMPI with mpirun or mpiexec like this:

$mpiexec -n 8 pyMPI <a_python_program.py>

cordially,

Jairo Serrano

2007/5/30, Ben Hitt < bhitt@wju.edu>:
Hello all
I have an 8 node MPICH2 cluster that the basic tests ( mpiexec -n 8 hostname, mpiexec -n 8 cpi and mpiexec -n 8 hellow) all work normally  I've installed pyMPI and it runs when called as $pyMPI on all 8 machines.  However when I run $mpiexec -n 8 pyMPI or mpirun -np 8 pyMPI no prompt, '$' or '>>>', is returned.  When I query each node '$ssh <node> ps -e | grep py' they all return pyMPI as an active process.  I've let the command sit for the better part of an hour with no response.  The same thing happens irrespective of values given to -n.  The use of machinefile likewise has no impact.
Any ideas?
Ben
--
Ben A. Hitt Ph.D.
Director
Schenk Center For Informatic Sciences
Wheeling Jesuit University
316 Washington Ave
Wheeling, WV 26003
(304) 243-2520
bhitt@wju.edu

"I say unto you: a man must have chaos yet within him to be able to give birth to a dancing star."
Thus Spake Zarathustra - Nietzsche
-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
Pympi-users mailing list
Pympi-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/pympi-users




--
jDSL
Bucaramanga, Colombia
UIS Rugby Club (c) 2007