#19 configure fails on Mac OS X

closed-fixed
None
5
2005-08-10
2004-10-20
Anonymous
No

configure fails on Mac OS X systems complaining that
libpython2.3.a cannot be found. The fact is that you do
not need libpythonX.Y.a on a Mac: you need to use the
"-framework Python" option in the linker.

I am using pyMPI 2.0b0 on Mac OS X 10.3.5 with the
stock python installation (python 2.3).

Discussion

  • Patrick Miller

    Patrick Miller - 2005-02-22

    Logged In: YES
    user_id=30074

    Hmmm.... I had been building against a custom python.
    I will modify the configure script to add this linker
    option.

    Normally, python will self report the build and link options
    for the C compiler, must be in a variable I didn't
    examine.

    I will merge this into the upcoming 2.4b0 release.

     
  • Patrick Miller

    Patrick Miller - 2005-02-22
    • assigned_to: nobody --> patmiller
     
  • Patrick Miller

    Patrick Miller - 2005-08-10

    Logged In: YES
    user_id=30074

    The new 2.4 beta fixes this. I built pyMPI with the system
    Python
    on a scratch Tiger install + developer tools + LAM MPI

     
  • Patrick Miller

    Patrick Miller - 2005-08-10
    • status: open --> closed-fixed
     

Log in to post a comment.