On Fri, May 1, 2009 at 3:57 AM, Luke Goodsell <luke.goodsell@gmail.com> wrote:
I'm trying to set up my machine to be able to run python scripts using
the PyMol API, but whenever I try to import the pymol module, I get the
following output:
. . .
 I am running Mac OS X 10.5.6. I downloaded MacPyMol 1.1r1 from
http://delsci.com/macpymol/ (the educational edition, as I am a student).
My PYMOL_PATH: /Applications/PyMOLX11Hybrid.app/pymol
My PYMOL_EXE: /Applications/PyMOLX11Hybrid.app/Contents/MacOS/MacPyMOL
. . .
 I copied the contents of /Applications/PyMOLX11Hybrid.app/pymol/modules
to /System/Library/Frameworks/Python.framework/Versions/2.5/lib/pymol,
as per my understanding of the top of __init__.py

It's not entirely clear to me what you're trying to do, but I'm pretty certain it's guaranteed not to work.  You can't just take compiled objects from inside app bundles and move them around - especially on Mac.  You definitely shouldn't be installing PyMOL modules that way.  If you need them available for importing by /usr/bin/python, download the open-source version from SourceForge and install it using python distutils (i.e. "python setup.py build" and so on).  I just tried this and it seems to work fine - only takes about 10 minutes.

-Nat