On Mon, Oct 10, 2011 at 2:58 AM, Tsjerk Wassenaar <tsjerkw@gmail.com> wrote:
Hey Lina,

It most likely is a consequence of the update. But the error comes
from the settings code, so I assumed that you set some settings at
startup, which brings a .pymolrc in mind. Not loading that file would
Right now I just simply removed the .pymolrc
Problem is still the same with

Detected OpenGL version 2.0 or greater.  Shaders available.
 PyMOLShader_NewFromFile-Error: Unable to open file '/usr/share/pymol/data/shaders/default.vs' PYMOL_PATH='/usr/share/pymol'
 PyMOLShader_NewFromFile-Warning: default shader files not found, loading from memory.
 PyMOLShader_NewFromFile-Error: Unable to open file '/usr/share/pymol/data/shaders/volume.vs' PYMOL_PATH='/usr/share/pymol'
 PyMOLShader_NewFromFile-Warning: volume shader files not found, loading from memory.
 Detected GLSL version 4.10.
 Detected 8 CPU cores.  Enabled multithreaded rendering.
Setting-Error: type read mismatch (float) -1

Recently I guess I updated lots of package, the detailed updated package in the recent four days includes:

Start-Date: 2011-10-07  21:05:49
Install: libnl3:amd64 (3.0-2, automatic)
Upgrade: libreoffice-style-galaxy:amd64 (3.4.3-1, 3.4.3-3), libplist1:amd64 (1.6
-2, 1.6-2+b1), libreoffice-draw:amd64 (3.4.3-1, 3.4.3-3), liblcms1:amd64 (1.19.d
fsg-1, 1.19.dfsg-1+b1), gnome-session-bin:amd64 (2.30.2-3+sid1, 2.30.2-3+sid2),
python-minimal:amd64 (2.6.7-3, 2.7.2-7), libreoffice-impress:amd64 (3.4.3-1, 3.4
.3-3), libimobiledevice2:amd64 (1.1.1-2, 1.1.1-2+b1), apache2-mpm-worker:amd64 (
2.2.20-1, 2.2.21-1), pymol:amd64 (1.4.1-1, 1.4.1-1+b1), gnome-session:amd64 (2.3
0.2-3+sid1, 2.30.2-3+sid2), libpolkit-gtk-1-0:amd64 (0.102-1, 0.102-2), gnome-se
ssion-common:amd64 (2.30.2-3+sid1, 2.30.2-3+sid2), libavogadro1:amd64 (1.0.3-1+b
1, 1.0.3-1+b2), python-all:amd64 (2.6.7-3, 2.7.2-7), ttf-opensymbol:amd64 (2.4.3
+LibO3.4.3-1, 2.4.3+LibO3.4.3-3), python-dev:amd64 (2.6.7-3, 2.7.2-7), libreoffi
ce-report-builder-bin:amd64 (3.4.3-1, 3.4.3-3), liblcms1-dev:amd64 (1.19.dfsg-1,
 1.19.dfsg-1+b1), libfcgi-perl:amd64 (0.73-2, 0.74-1), apache2-utils:amd64 (2.2.
20-1, 2.2.21-1), libreoffice-math:amd64 (3.4.3-1, 3.4.3-3), apache2:amd64 (2.2.2
0-1, 2.2.21-1), libreoffice-common:amd64 (3.4.3-1, 3.4.3-3), python-avogadro:amd
64 (1.0.3-1+b1, 1.0.3-1+b2), apache2.2-common:amd64 (2.2.20-1, 2.2.21-1), uno-li
bs3:amd64 (3.4.3-1, 3.4.3-3), deskbar-applet:amd64 (2.32.0-1+b2, 2.32.0-1+b3), p
ython-uno:amd64 (3.4.3-1, 3.4.3-3), python:amd64 (2.6.7-3, 2.7.2-7), sudo:amd64
(1.8.2-1, 1.8.2-2), libwpd-0.9-9:amd64 (0.9.3-1, 0.9.3-2), apache2.2-bin:amd64 (
2.2.20-1, 2.2.21-1), policykit-1-gnome:amd64 (0.102-1, 0.102-2), avogadro:amd64
(1.0.3-1+b1, 1.0.3-1+b2), openoffice.org:amd64 (3.4.0~ooo340m1-3, 3.4.0~ooo340m1
-5), wpasupplicant:amd64 (0.7.3-3, 0.7.3-4), libtotem-plparser17:amd64 (2.32.5-2
, 2.32.6-1), ure:amd64 (3.4.3-1, 3.4.3-3), libreoffice-base-core:amd64 (3.4.3-1,
 3.4.3-3), libreoffice-base:amd64 (3.4.3-1, 3.4.3-3), libreoffice:amd64 (3.4.3-1
, 3.4.3-3), libreoffice-calc:amd64 (3.4.3-1, 3.4.3-3), libpq5:amd64 (9.1.0-1, 9.
1.1-1), libreoffice-officebean:amd64 (3.4.3-1, 3.4.3-3), libreoffice-emailmerge:
amd64 (3.4.3-1, 3.4.3-3), python-all-dev:amd64 (2.6.7-3, 2.7.2-7), libreoffice-j
ava-common:amd64 (3.4.3-1, 3.4.3-3), libreoffice-filter-mobiledev:amd64 (3.4.3-1
, 3.4.3-3), pdb2pqr:amd64 (1.7-2, 1.7-2+b1), libreoffice-filter-binfilter:amd64
(3.4.3-1, 3.4.3-3), libjs-jquery:amd64 (1.6.2-1, 1.6.4-1), libreoffice-core:amd6
4 (3.4.3-1, 3.4.3-3), libreoffice-writer:amd64 (3.4.3-1, 3.4.3-3)
End-Date: 2011-10-07  21:15:12

Start-Date: 2011-10-07  23:59:10
Upgrade: python3-minimal:amd64 (3.2-3, 3.2.2~rc1-2), python3-dev:amd64 (3.2-3, 3
.2.2~rc1-2), python3-doc:amd64 (3.2-3, 3.2.2~rc1-2), python3.2-minimal:amd64 (3.
2.1~rc1-1, 3.2.2~rc1-1), libpython3.2:amd64 (3.2.1~rc1-1, 3.2.2~rc1-1), python3.
2:amd64 (3.2.1~rc1-1, 3.2.2~rc1-1), python3.2-examples:amd64 (3.2.1~rc1-1, 3.2.2
~rc1-1), python3:amd64 (3.2-3, 3.2.2~rc1-2), idle3:amd64 (3.2-3, 3.2.2~rc1-2), p
ython3.2-dev:amd64 (3.2.1~rc1-1, 3.2.2~rc1-1), python3.2-doc:amd64 (3.2.1~rc1-1,
 3.2.2~rc1-1), python3-examples:amd64 (3.2-3, 3.2.2~rc1-2)
End-Date: 2011-10-08  00:00:57

Start-Date: 2011-10-08  16:17:23
Upgrade: libatk1.0-0:amd64 (2.0.1-2, 2.2.0-1), mgltools-pybabel:amd64 (1.5.6~rc1
+cvs.20110617-1, 1.5.6~rc2+cvs.20110926-1), mgltools-webservices:amd64 (1.5.6~rc
1+cvs.20110703-1, 1.5.6~rc2+cvs.20110926-1), libatk1.0-data:amd64 (2.0.1-2, 2.2.
0-1), mgltools-volume:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc2+cvs.20110926-1)
, mgltools-mglutil:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc2+cvs.20110926-1), l
ibtdb1:amd64 (1.2.9-3, 1.2.9-4+b1), mgltools-scenario2:amd64 (1.5.6~rc1+cvs.2011
0617-1, 1.5.6~rc2+cvs.20110926-1), infernal:amd64 (1.0.2-1, 1.0.2-2), libfuse2:a
md64 (2.8.5-5, 2.8.6-1), autodocktools:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc
2+cvs.20110926-1), mgltools-viewerframework:amd64 (1.5.6~rc1+cvs.20110617-2, 1.5
.6~rc2+cvs.20110926-1), mgltools-pyglf:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc
2+cvs.20110926-1), mgltools-opengltk:amd64 (1.5.6~rc1+cvs.20110625-1, 1.5.6~rc2+
cvs.20110926-1), mgltools-geomutils:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc2+c
vs.20110926-1), gir1.2-atk-1.0:amd64 (2.0.1-2, 2.2.0-1), mgltools-gle:amd64 (1.5
.6~rc1+cvs.20110617-1, 1.5.6~rc2+cvs.20110926-1), liborc-0.4-0:amd64 (0.4.14-1,
0.4.15-2), mgltools-support:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc2+cvs.20110
926-1), mgltools-bhtree:amd64 (1.5.6~rc1+cvs.20110617-1, 1.5.6~rc2+cvs.20110926-
1)
End-Date: 2011-10-08  16:19:54

Start-Date: 2011-10-08  22:02:42
Upgrade: ia32-libs:amd64 (20110609, 20111001), ia32-libs-gtk:amd64 (20110310, 20
111001)
End-Date: 2011-10-08  22:03:21

Start-Date: 2011-10-09  22:09:51
Upgrade: libtalloc2:amd64 (2.0.7-1, 2.0.7-3), gcalctool:amd64 (6.0.2-1, 6.2.0-1)
, python-minimal:amd64 (2.7.2-7, 2.7.2-8), zenity:amd64 (3.0.0-2, 3.2.0-1), libp
angomm-1.4-1:amd64 (2.28.2-1, 2.28.3-1), python-all:amd64 (2.7.2-7, 2.7.2-8), li
bgweather-3-0:amd64 (3.0.2-1, 3.2.0-1), libwps-0.2-2:amd64 (0.2.2-1, 0.2.3-1), p
ython-dev:amd64 (2.7.2-7, 2.7.2-8), libgweather-common:amd64 (3.0.2-1, 3.2.0-1),
 libp11-kit0:amd64 (0.6-1, 0.7-2), python:amd64 (2.7.2-7, 2.7.2-8), libdjvulibre
21:amd64 (3.5.24-8+b1, 3.5.24-9), libunique-3.0-0:amd64 (3.0.0-1, 3.0.2-1), libd
vdread4:amd64 (4.1.4-1219-2, 4.1.4-1219-4), gimp:amd64 (2.6.11-4, 2.6.11-5), lib
gimp2.0:amd64 (2.6.11-4, 2.6.11-5), zenity-common:amd64 (3.0.0-2, 3.2.0-1), pyth
on-all-dev:amd64 (2.7.2-7, 2.7.2-8), libdjvulibre-text:amd64 (3.5.24-8+b1, 3.5.2
4-9), libgssglue1:amd64 (0.3-3, 0.3-3.1), gimp-data:amd64 (2.6.11-4, 2.6.11-5),
dmidecode:amd64 (2.9-1.2, 2.11-3)
End-Date: 2011-10-09  22:14:12


then solve it, although the problem is probably more fundamental, and
I would suspect you'd get an error like that when just setting some
setting in Pymol. If you can give more information regarding the
modules that were updated, it would be very helpful. Otherwise, I'm
Yesterday I re-installed the pymol, everything kept it as original, did not install some plugins and others.
 
rather clueless... 

Cheers,

Thanks again,
 
Tsjerk