Hi.

Well, I don't know really what you wan't, but I remember pain with graphics and computers. :-)

I see the same error (X Error of failed request....) when I get a kernel update to my CentOS comp.
That screws up my NVIDIA driver installation, pymol fails, and I have to reinstall the driver package.

The term "LIBGL_ALWAYS_INDIRECT=1", is controlling something with which method draws the window.
By OpenGL or by the mesa driver. (Something like that).
The OpenGL is super fast, and mesa driver is slow.

Our shared installation of pymol, means that computers with the NVIDIA driver works super fast, while
the computers which havent an updated NVIDIA driver is just running slow. (Pain slow).

If this can help, our execution script for pymol is:

----------------------------------------------------------------------
[tlinnet@tomat pymolsvn]$ cat pymolMPEG.sh
#!/bin/bash
if [ ! -f $HOME/.local/share/applications/pymolsvn.desktop ];
then
ln -s /ourlab/software/pymolsvn/pymolsvn.desktop $HOME/.local/share/applications/pymolsvn.desktop
fi

export FREEMOL=/ourlab/software/pymolsvn/svnfreemol/freemol
export PYMOL_GIT_MOD=/ourlab/software/pymolsvn/Pymol-script-repo/modules
export PYTHONPATH=$PYTHONPATH:/ourlab/software/x64/lib64/python2.6/site-packages/PIL
export PYTHONPATH=$PYTHONPATH:/ourlab/software/x64/lib64/python2.6/site-packages/lib-tk
export PYTHONPATH=$PYTHONPATH:/ourlab/software/x64/lib64/python2.6/site-packages/lib-dynload
export PYTHONPATH=/ourlab/software/pymolsvn/Pymol-script-repo/modules:$PYTHONPATH
export PYTHONPATH=/ourlab/software/pymolsvn/Pymol-script-repo:$PYTHONPATH
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/ourlab/software/x64/lib/pymollib
export LIBGL_ALWAYS_INDIRECT=no

/usr/bin/python /ourlab/software/pymolsvn/modules/pymol/__init__.py "$@"

------------------------------------


Best
Troels Emtekær Linnet
Ved kløvermarken 9, 1.th
2300 København S
Mobil:
+45 60210234


2013/2/7 <m.roth@5-cent.us>
Hi, folks,

If there's a howto or FAQ on this, please give me a pointer.

We've recently install pymol on several systems. We're running CentOS 6.3,
and the yum installed pymos is 1.3.3.20100705svn3911

ssh -Y into other workstations lets me run it with no problem. However, if
I do the same to a headless server, on which X is *not* running (if that
makes any difference - it is installed), results in
freeglut (pymol):  ERROR:  Internal error <FBConfig with necessary
capabilities not found> in function fgOpenWindow
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  4 (X_DestroyWindow)
  Resource id in failed request:  0x0
  Serial number of failed request:  33
  Current serial number in output stream:  36
 PyMOL: abrupt program termination.

When I first log in, glxgears also doesn't run. Having done a lot of
googling, once I execute
export LIBGL_ALWAYS_INDIRECT=1
glxgears runs, albeit slowly and irregularly (faster, slower, etc).
However, pymol still gives me the same errors (and I have read that there
are two of them, the freeglut and the X error.

Any solutions? workarounds?

Thanks in advance.

        mark, sysadmin, not researcher


------------------------------------------------------------------------------
Free Next-Gen Firewall Hardware Offer
Buy your Sophos next-gen firewall before the end March 2013
and get the hardware for free! Learn more.
http://p.sf.net/sfu/sophos-d2d-feb
_______________________________________________
PyMOL-users mailing list (PyMOL-users@lists.sourceforge.net)
Info Page: https://lists.sourceforge.net/lists/listinfo/pymol-users
Archives: http://www.mail-archive.com/pymol-users@lists.sourceforge.net