Hi Jason,
Thanks for your reply. This was indeed a driver problem . Ubuntu had pushed a natty kernel headers to lucid users by mistake and that update broke my nvidia 195.36.24 x86_64 driver. To fix it , In desperation,  I updated to the 270.xx series nvidia driver from the nvidia website which I then used to compile and run pymol . That configuration gives the errors that I mentioned in my  email. 

Coot and the other opengl programs worked well when I was running the 270.xx series driver , but pymol was compiling but giving the "bad Request" errors. This is probably related to the the 270.xx problems that other users wrote in about.

Regardless, I reverted to the 195.36.24 series driver , re-ran the distutils build and now have pymol 1.4.1 running on my machine


Thanks for your help.

Hari


 

I have since 

On Wed, Jun 8, 2011 at 5:05 PM, Jason Vertrees <jason.vertrees@schrodinger.com> wrote:
Hari,

>  Hit ESC anytime to toggle between text and graphics.
>  Detected OpenGL version 2.0 or greater.  Shaders available.
> X Error of failed request:  BadRequest (invalid request code or no such
> operation)
>   Major opcode of failed request:  128 (GLX)
>   Minor opcode of failed request:  169 ()
>   Serial number of failed request:  46
>   Current serial number in output stream:  46

This sounds like a driver problem.  Can you run the 'glxgears'
program?  Does it give the same error?  Do you have the latest driver
installed?

Cheers,

-- Jason

--
Jason Vertrees, PhD
PyMOL Product Manager
Schrodinger, LLC

(e) Jason.Vertrees@schrodinger.com
(o) +1 (603) 374-7120