Good afternoon,

Sorry for posting twice, just in case the previous one with attached screenshots
is too large to be posted.

I've been having problems with color rendering when using PyMOL on a laptop
with an Intel graphics card. This only occurs when used with linux (I've tested
Fedora 11, Fedora 12, and Ubuntu 10.04), but not when using Windows Vista
on the same laptop. The main problem is that the color rendering for the stick
drawing method does not work right.

I can send screenshots if needed. These screenshots use the stick drawing with
coloring supposed to be by element. But the coloring is not at all done by element,
instead some regions get clustered by different colors. Just to note, the coloring
for drawing by line does seem to work fine.

I've googled this for some time now, and couldn't find any resolution. Just to note,
I also have this problem with VMD's licorice rendering (its version of stick). Again,
both work fine on Windows but not on the linux distros I've tested so far. I'm not sure
if this'll be helpful, but here's the output of glxinfo | grep -i opengl:

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20091221 2009Q4
OpenGL version string: 2.1 Mesa 7.7.1
OpenGL shading language version string: 1.20

As an aside, I used to have a problem with a flickering display, but this was fixed by
turning off desktop effects like compiz. For this coloring problem, is there some
X setting that needs to be maybe tweaked for Intel graphics cards?

Thanks for any help on this.

Thanks again,
Timothy