Hi folks,

I just upgraded my Ubuntu Linux installation to 11.10.  Of course, this removes obsolete versions of applications.  So I had to reinstall PyMol.

The Ubuntu Linux 11.10 manifest states that PyMol 1.4.1 is the supported version, and a package file is available.  So, I downloaded and (supposedly) installed PyMol 1.4.1 -- first through Ubuntu Software Center, and then through Synaptic Package Manager when Software Center failed (I didn't expect it to to make a difference, but I tried anyway).

The way in which PyMol is failing is very simple.  When I click on the PyMol icon to start the application, nothing happens.

There were no error messages visible in the GUI during the installation, nor when attempting to start the application.  So next I tried to run PyMol from a terminal prompt, and here I saw errors:

23:29:55 -> pymol
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named pymol
/usr/local/bin/python2.7: No module named pymol

This tells me that there's an executable file on my system path named pymol.py, which starts.  Then pymol.py tries to import a module, also named pymol (why is the name "pymol" used twice?), which fails.

I'm a bit baffled at this behavior, especially as it comes from a standard package file.  Any help you might offer is appreciated.