ImportError: No module named _ckernel

  • mark pearrow

    mark pearrow - 2008-08-14

    I've tried building PyML 0.7.0 on three different Debian permutations:

    1) 64-bit Etch, Python 2.4
    2) 64-bit Etch, Python 2.5
    3) 64-bit Lenny, Python 2.5

    In all cases, once I have built PyML and installed it, when I try to import it I get the following error:

    >>> import PyML
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
      File "PyML/", line 4, in <module>
        from PyML.containers import *
      File "PyML/containers/", line 3, in <module>
        VectorDataSet = __import__('PyML.containers.vectorDatasets', fromlist=['']).VectorDataSet
      File "PyML/containers/", line 4, in <module>
        from PyML.containers.baseDatasets import WrapperDataSet, BaseVectorDataSet
      File "PyML/containers/", line 4, in <module>
        from PyML.containers import ker
      File "PyML/containers/", line 6, in <module>
        from ext import ckernel
      File "PyML/containers/ext/", line 7, in <module>
        import _ckernel
    ImportError: No module named _ckernel

    Any idea what is happening? I can see that exists, is readable, is in the pythonpath, and seems to be OK as far as what it is linked against:

   =>  (0x00007fff3a3fe000)
   => /usr/lib/ (0x00007fca31e0e000)
   => /lib/ (0x00007fca31b8b000)
   => /lib/ (0x00007fca31973000)
   => /lib/ (0x00007fca31757000)
   => /lib/ (0x00007fca31404000)
            /lib64/ (0x00007fca32379000)


    • Ralfe Poisson

      Ralfe Poisson - 2009-04-10

      Has this been solved?

      I am having the same problem.


  • Adam Oakman

    Adam Oakman - 2010-01-24

    I'm having the same issue on Mac OSX, any solution?

  • Pablo Antonio

    Pablo Antonio - 2010-02-23

    I was having the same problem here, and I found "a solution".

    It has to do with Python's search path. When importing a module, Python first tries to find it in the current directory. If it's not there, then it goes and look at every directory in



    You probably tried to import the PyML module while in the directory created after extracting the tar.gz. That directory has a


    directory with a file called

    in it. The existence of that file make that directory a Python module. So, when you tried to import the PyML module, Python found it there, and that module wasn't the one you wanted.

    The "solution" is to


    into some other directory and try the import again.

  • Pablo Antonio

    Pablo Antonio - 2010-02-23

    Sorry for my last comment's markup. I didn't know the "code tag" would be that ugly, and that Sourceforge wouldn't let me preview and/or edit my comment.


Log in to post a comment.