#23 DeprecationWarning: the md5 module is deprecated; use hashli

closed-fixed
Roman
None
5
2011-02-26
2010-08-07
Aron Xu
No

Hello, pygccxml generates the following warning:

/usr/lib/pymodules/python2.6/pygccxml/parser/declarations_cache.py:8: DeprecationWarning: the md5 module is deprecated; use hashlib instead

Please consider to change it, perhaps it isn't a difficult thing, :)

This is originally Debian BTS #588843 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=588843)

Discussion

  • Aron Xu

    Aron Xu - 2010-11-13

    Use hashlib instead of md5 module

     
  • Roman

    Roman - 2011-02-26

    It looks like this bug was fixed long time ago.

     
  • Roman

    Roman - 2011-02-26
    • assigned_to: nobody --> roman_yakovenko
    • status: open --> closed-fixed
     

Log in to post a comment.