So the changed format would be:
I also plan to extend the interface of the PythonNatureStore:
setPathProperty(QualifiedName key, String value)
Seems a nice format to me ;-)
These methods would deal with the second property type. The PythonPathNature would use these path properties.
Later (when someone has the time :-) ) additional PathProperty accessors could be defined so that the internal PyDev code doesn't need to deal with the splitting / joining of strings:
String getPathProperty(QualifiedName key)
setPathProperty(QualifiedName key, String paths)
What do you think?