Helo!
I don't know if this should be done through here, but I would like to request for future releases, the syntax highlight support for .pxd and .pxi files (Cython Support Enhancement).
Currently, PyDev only supports .pyx and adding the other extensions to the Valid source Files list, doesn't do anything. I'm using the 3.0.0.201311051910 PyDev version.

--

Carlos Miguel Ferreira
Researcher at Telecommunications Institute
Aveiro - Portugal
Work E-mail - cmf@av.it.pt
Skype & GTalk -> carlosmf.pt@gmail.com
LinkedIn -> http://www.linkedin.com/in/carlosmferreira