Hey Fabio,
Thanks for the quick response.  It does seem pretty strange.  I have never used git before, so I am reading up on it a bit.  I note that when using gitk to examine the repo, the capitalization is correct.  However, from the repo directory in linux (Ubuntu Jaunty), I see the following in all relevant plugins:

drogers@xps420:/share-fat/pydev/Pydev$ ls
builders  features  make_release.py  plugins  remove_unversioned_files.py
drogers@xps420:/share-fat/pydev/Pydev$ find . -iname meta-inf

drogers@xps420:/share-fat/pydev/Pydev$ find . -iname manifest.mf
./p lugins/org.python.pydev.runalltests/meta-inf/manifest.mf

I will fix the issue locally, however if anyone has any insight to the situation, it would be greatly appreciated.


--- On Sat, 9/12/09, Fabio Zadrozny <fabioz@esss.com.br> wrote:

From: Fabio Zadrozny <fabioz@esss.com.br>
Subject: Re: [Pydev-code] Pydev project dependencies
To: pydev-code@lists.sourceforge.net
Date: Saturday, September 12, 2009, 3:51 PM

Hi Fabio,
I've been working on some test driven development functionality for Pydev.  While I am psyched that you have been able to open source Pydev Extensions so we can work with the code, I'm having issues with most of the projects not building in linux.  This is separate from needing to create the local testing data files--this I have down fine as I've been working with the pydev source from the subversion repo for a while.  Rather, after importing the projects from my local git repo, and then dealing with the TestDependent.java, most of the projects indicate red error markers in the package explorer that resolve down to all imports:
import eclipse.org.**
not being recognized.
When I look at the plugin.xml in any of the affected projects, there are *no* dependencies listed in the dependency tab.  I have also noted that in the overview tab of the plugin.xml, there is a link to create an osgi bundle for the project--so the bundle information is not being read.  I also note that the META-INF folder is actually named meta-inf in the package explorer, and the MANIFEST.MF is in lower case as well.  I run windows xp in a vm and note that these file names are correctly capitalized, and all of the dependencies show in the plugin.xml dependencies tab.  After tweaking the .
I was wondering if this is something that should be fixed in the repo, or perhaps is an issue with git on my end?

Have a good one,

Hi Dave,

That seems really strange... The capitalization of things seems correct for me (at least on my machine) and I've browsed the tree at github (http://github.com/aptana/Pydev/tree/master) and it seems correct there too. Also, although I still haven't built Pydev on linux after going to github, it was being regularly built before (doing nightly builds -- right now it's still not ported to github), so, it seems it's something on your side (although I'm not sure what could that be).

Anyone else there building on Linux can verify that?



-----Inline Attachment Follows-----

Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july

-----Inline Attachment Follows-----

pydev-code mailing list