PIL import problem

2007-03-26
2013-03-15
  • Tony Perkins

    Tony Perkins - 2007-03-26

    Just installed eclipse on ubuntu with pydev extensions 1.3.1.

    When I create a file and type the following

    from PIL import

    Autocomplete gives me 3 items.

    _imaging
    _imagingft
    _imagingmath

    ( these are actually .so files in the site-packages/PIL/ dir.

    I'm trying to simply do

    from PIL import Image

    Which works fine from the prompt and other IDEs like SPE.

     
    • Fabio Zadrozny

      Fabio Zadrozny - 2007-03-26

      Try putting PIL in your forced builtins: http://www.fabioz.com/pydev/manual_101_interpreter.html

      Cheers,

      Fabio

       
    • Steve Lianoglou

      Steve Lianoglou - 2007-03-26

      This actually works for me on Eclipse 3.2.2 and PyDev 1.3.0 -- I'm just about to update to 1.3.1, but I don't think that should be a problem.

      For the record, PIL isn't in my forced builtins (I've had greater success keeping stuff out of there, actually).

      In the `from PIL import <ctrl-space>` popup, I get Image

      Then, if I do an Image.<ctrl-space> I get relevant method completions as well ...

      -steve

       
    • Tony Perkins

      Tony Perkins - 2007-03-27

      What makes it even more interesting is that I have pretty much the same setup on my home PC and it works fine. It's on my work laptop that I'm having this issue.

      Thanks for the replies, I'll give the forced route a shot.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks