problem with the debugger

Yoav Rubin
  • Yoav Rubin

    Yoav Rubin - 2006-09-19

    Hi All, when i run my project in the run mode, the project runs fine, but when i run it in the debugger and place a breakpoint somewhere i get an error message in the console that sais that one of my imports (which is one of the modules i created in the project) does not exist. Does anyone has any idea what to do, i'm a newbie in pydev and python,


    • Fabio Zadrozny

      Fabio Zadrozny - 2006-09-23

      Which pydev/eclipse version are you using? Can you paste that message?

    • Lee Connell

      Lee Connell - 2006-09-30

      I have same problem as well.  I am running 1.2.4 pydev and eclipse 3.2.  If i use "from mod1 import MyClass" or if i use "import mod1" and use "yo = mod1.MyClass" I get the following error in debugger which actually thinks my class is a different name.  MyClass definately is defined in within MyPack package as code completion works just fine as far as I can tell.


      from mod1 import MyClass

      yo = MyClass()


        File "C:\Documents and Settings\Lee Connell\workspace\Test\src\MyPack\", line 12, in Doh
          clazz = MyClOass(self)
      NameError: global name 'MyClOass' is not defined


      If I use "import mod1" and use "yo = MyClass()" I it doesn't know what MyClass is which it should.


      File "C:\Documents and Settings\Lee Connell\workspace\Test\src\MyPack\", line 5, in ?
          yo = MyClass()
      NameError: name 'MyClass' is not defined

      • Lee Connell

        Lee Connell - 2006-09-30

        Well I apologize, I tried to remove my post but I don't see the option.  I clearly misread the debugger output, and I was looking in the incorrect file.  The debugger was completely right :|

        • Fabio Zadrozny

          Fabio Zadrozny - 2006-09-30

          No problems ;-)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks