Run as\Python run missing

  • Nobody/Anonymous


    I´m new into eclipse and Pydev and wanted to start with the small tutorial on

    Unfortunatly I stuck at the point "Select Run as\Python run.". In this menu I only have Java-Run-Options to choice and "Run". If I click on "Run" I have to set up a Python Run Configuration before I get the Run-button. Don´t know what values to fill in.

    The path is set correctly in the properties of the project and the python-interpreter is right in window/preferences. Something is wrong here, but don´t know what. Do you?

    • Fabio Zadrozny

      Fabio Zadrozny - 2005-12-02

      Hi, maybe your 'run settings' are not well configured in your perspective (go to window > customize perspective > commands and check the 'launch' item).

      If that does not solve it, please report back again.



    • Daniel Brodie

      Daniel Brodie - 2005-12-07

      Although I am not the parent poster, I have the same problem. I checked the Launch item (it wasn't checked) but it didn't work.

      I am using:
      Eclipse 3.1.1
      on Ubuntu Linux Breezy


    • Nobody/Anonymous

      I guess you miss your jre path.
      you can check your java path:
          ls -l /usr/bin/java
      to check if it link to a correct path, like
      or you can disconnect the link
          mv /usr/bin/java /usr/bin/java_bak
      and add correct PATH, JAVAHOME, and CLASSPATH in your ~/.bash_profile(and execute source ~/.bash_profile if you don't wanna reboot)
          check your PATH use:

    • Nobody/Anonymous

      Hi, but how do I set the jre path in Windows??


      • - 2005-12-28

        You set your JRE path within eclipse without regard to your platform, be it windows, linux, or whatever.  In the "Package Explorer" window single click on the package name.  Press Alt-Enter to bring up the properties window.  Choose the "Java Build Path" option on the left which will bring up a tabbed dialog on the right.  Choose the "Libraries" tab.  With the buttons on the left you can add individual jar files that are not built by eclipse (called external jars) or add a directory of external jars with the "Add Library..." button.  The order in which the jars are searched is set on the "Order and Export" tab of the same "Java Build Path" dialog.

        • Baishampayan Ghose

          I also had the same problem of not being able to find the Python Run item in the menu. It absolutely freaked me out. It got added again when I re-added my Python interpreter in the perspective config window.

      • - 2005-12-28

        Sorry, the first message was a bit off-topic for what anonymous was telling a linux user to do.  On Windows the install process takes care of writing the path data to the registry and as long as you don't do anything foolish (like move the directory after the install) it just works.  If you want to see that the data in the registry for your JRE path is correct do (for XP) start - Run.. - regedit and in regedit look at HKEY_LOCAL_MACHINE / SOFTWARE / JavaSoft / Java Runtime Environment / 1.5 and check that the JavaHome key points to the directory that is the root of your JRE (that is has a bin directory in it and java.exe and javaw.exe within that.

    • Anonymous - 2006-01-05

      I tried checking the "launch" box in the perspective details and it works now under linux.
      Perhaps this could be made the default when installing pyDev

    • Nobody/Anonymous

      Ensure you haven'n forgot the .py extension (e.g. not only Py1).

      That was my problem. Now it works well.

    • Nobody/Anonymous

      I have the exact same situation described by the orig poster.  Are there any other things to check?
      -The interpreter and PYTHONPATH seem correct.
      -I checked launch and it was already checked.
      -My files have a .py extension.

      I'm using Fedora Core 4, Eclipse 3.1.2, Pydev 1.0.1

    • Billy B

      Billy B - 2006-02-14

      I thought it wasn't working at first too.  Be sure you're right-clicking ON THE .py FILE ITSELF in the Navigator, and not the project folder it's contained in.

      That did it for me at least.

    • Nobody/Anonymous

      I think the fact that I'm a rookie with eclipse is my main problem.  I didn't realize you had to define a new run configuration (I thought that was just to do specialized things).  At any rate, once I made a new run config and entered the project and main mdule things miraculously started working.

    • Nobody/Anonymous

      Yes, it is helpful.  What was confusing is that on the "running" page it seemed like option 4 "python run" on the run as menu would automatically be there instead of being something that had to be created by hand by the user.

      • Fabio Zadrozny

        Fabio Zadrozny - 2006-02-25

        You should try the tutorial at:

        It gives you a better 'how-to', and you *should* have the run as > python if you configure your perspective correctly.



    • onamatic

      onamatic - 2006-06-26

      I have exactly the same problem with "Run As - Python".
      I'm using Fedora Core 5, Eclipse 3.1.2, Pydev 1.2.0

      After 8 hours I have now managed to get debugging working (very well indeed!) by kicking things off from the debug toolbar button but I have never managed to get Run As - Python on a context menu. 

      The best I can do is to click on the source folder which then gives "Run As - Python Coverage" and "Run As - Python unit-test" (I think these came from Pydev extensions which I downloaded in error/desperation.)

      I have read manual_101_root.html and the FAQ - they did not help.

      Have I got the right versions of Eclipse and Pydev? "Pydev Adventures" ( says :

      "This release (1.2.0) focused mainly on making pydev compatible with Eclipse 3.2 (so support for Eclipse 3.1 is now discontinued)."

      (I couldn't find Eclipse 3.2 anywhere)

      Any  thoughts gratefully received.

      • Fabio Zadrozny

        Fabio Zadrozny - 2006-06-26

        Are you using the pydev perspective?

    • onamatic

      onamatic - 2006-06-26

      Hi Fabio,

      Thanks for helping me.

      I sure am using the Pydev perspective.

      The Pydev perspective has the "Launch" option checked. The Menubar details show "Run As" (plus all the other items as normal) and the Toolbar details for the Launch toolbar show the Debug and Run options with the correct configurations (that's why the tollbar buttons work I guess!)

      [ En passant, although probably nothing to do with the "Run As" problem, I notice that during a debug session I get many Error log messages :
      Error 2006-06-26 13:02:54.828 Unexpected treadRun payload -1208847892    108

      The code executes fine though. Just thought I'd mention it in case.]

      Thanks again,


      • Fabio Zadrozny

        Fabio Zadrozny - 2006-06-27

        Ok, the problem *might* be the Eclipse version... You can get the Eclipse version at

        (3.2 RC7 is the release candidate 7 for Eclipse. The final one should be out in about a week).

        Or you can try downgrading pydev to 1.1.0.



        • onamatic

          onamatic - 2006-06-27

          Hi Fabio,

          Something went horribly wrong upgrading to 3.2RC7 - so now I can't run Eclipse at all - I'll report back when I've sorted the mess out.



          • onamatic

            onamatic - 2006-06-28


            I'm now running Eclipse 3.1.2 and Pydev 1.1.0.

            When I installed Pydev via Help-> Find & Install
            the installation appeared to fail:

            Unable to complete action for feature "PyDev for Eclipse due to errors.

            (I remember that this also happened when I  installed PyDev 1.2.0 originally)

            It seems as though PyDev acually installed OK though (except for Run as\Python) and the Run/Debug toolbar buttons work fine as usual.

            This is just for your info, I'm happy enough as things stand (unless something suddenly comes to your mind)! Thanks for your help.