Python Comment keybinding: unusual problem!

  • Alan

    Alan - 2006-12-07

    Hello, I'm using Eclipse 3.2 with Ubuntu Edgy.

    Eclipse SDK

    Version: 3.2.1
    Build id: M20060921-0945 (Ubuntu version: 3.2.1-0ubuntu1)

    I experienced the strange problem I describe belows, so I tried a full-reinstall of eclipse and all libraries; the problem persists even with a brand new install and a brand new workspace.

    the system is fully updated. Eclipse SDK and libraries are those that come with Ubuntu, while pydev 1.2.5 + pydev extensions were installed from the official repository (i never installed the pydev provided by ubuntu to prevent conflicts). The only addition is Lunar Editor Enhancements, but I've verified the issue arises even removing it.

    I can't tell exactly when/what happened, it was yesterday or today... I'm not able to to bind Ctrl+3 as Python Comment!

    If I try (beside the fact that a kind of blueish triangle appears at the left of the scope in Preferences -> Keys -> Modify, but I think it means something like 'User defined').

    I tried removing all bindings for Ctrl+3 after taking a look at Keys->View (it was assigned to Python Comment only, BTW) and then setting it again to "Python Comment" in "Pydev editor" scope.

    Nothing happens! If I try using it, it's just like the selected text blinks and nothing more.

    After trying for a while, I removed the ctrl+2 keybinding (something for 'offline scripting' or  similar) and assigned it to Python Comment; works 100%.

    Then I tried using Ctrl+3 (no keybinding is defined! in keys->view I simply see nothing under ctrl+3)... and it works a Python Uncomment, which is bound to Shift+Ctrl+3 instead (but shift+ctrl+3 works as well).

    I work with an external usb keyboard on a laptop, so I thought there might be something weird with it, I don't know, some strange keycode emitted, so I went back to the internal keyboard, I tried saving & rebooting everything, and the behaviour stays the same.

    Today Ubuntu released a lot of updates regarding gtk/glib and other important gui-related libraries... I don't know whatever other change has happened to my system. I'm posting this to the ubuntu forums as well... I tried looking for any enabled assistive technology, but it doesn't seem the case: if I press ctrl+downarrow I don't get the shift+ctrl+downarrow functionality.

    Let me know if you have any idea and/or how can I post any debug information you could need.


    • Fabio Zadrozny

      Fabio Zadrozny - 2006-12-09

      Can you try the following:

      In a line with:


      if you press Ctrl+4 in that line, the result should be:


      and when pressing Ctrl+Shift+4 in the same line, it should be:

      #------ block

      Can you try and see if that's what you get?

      I'm asking because I had a report about this and I think that they might be related...



    • Alan

      Alan - 2006-12-09

      yes.. they could be related. By using both key combos I get this:

      #------------------------------------------------------------------------- block

      #------------------------------------------------------------------------- block

      Which is the ctrl+shift+4 behaviour, I think.

      • Fabio Zadrozny

        Fabio Zadrozny - 2006-12-09

        Seems something related to the mapping of your keys... it appears that 'Shift' is actually being active when you press 'Ctrl'... I can't say exactly what, but that seems something related to your system configuration.

        So, it could be in the Ubuntu Edgy side or in the Eclipse side -- I'd try reporting it in Ubuntu and in -- although I think it is more likely to be in the Ubuntu Edgy side... (or maybe it could be in the java distribution) you could check to see if this behaviour also happens in some other program -- java and not java, so you can track down if it is actually related only to the system or to java in you system or to only Eclipse in your system ;-).

        -- Pydev does not actually do anything on that part (the framework provided by Eclipse should be responsible for handling the keybindings)...



    • Alan

      Alan - 2006-12-10

      OK, mr. Zadrozny!

      BTW, this doesn't happen in other places in Ubuntu, nor in other functions in Eclipse; I did make some tests before reporting this issue to you.

      As an example: in Eclipse, Ctrl+F4 is 'Close File', while Ctrl+Shift+F4 is 'Close all files'. If I press Ctrl+F4 I get just the currently selected file to be closed, not all files.

      But you seem to be right on the behaviour about numbers! I tried rebinding 'python uncomment' to Shift+Ctrl+1, while Ctrl+1 means' Quick Assist' in pydev... and by pressing just ctrl+1 I get the python uncomment function!

      But, again... this seems related to Pydev, not to the full Eclipse nor Ubuntu (I don't know why, I know this *doesn't* mean the bug is in Pydev or Extensions, just giving you some clues).

      What I did:
      I created a new Java project and created a Java class.
      Then I bound Source->Comment to Ctrl+Shift+1 , Ctrl+1 is already bound to 'Quick Fix'. Both combos work correctly.

      I'll do what I can. I'll test with an out-of-the box install from instead that the one provided with Ubuntu. BTW I'm using the official Java interpreter from Sun, not eclipse-gcj, so I don't think this could be related to the Java interpreter.

    • Alan

      Alan - 2006-12-12

      I've just tried the stock eclipse 3.2.1 sdk distribution from, with just pydev (no extensions) installed. I tested back to pydev version 1.2.3, and the problem appears there as well. I'd say it's something related to gtk and/or with the swt-gtk libraries of Ubuntu. Or maybe with Eclipse, but there should be far many users reporting this in that case.

      Have you already reported this bug to ubuntu launchpad? If not, tell me and I will.

      • Fabio Zadrozny

        Fabio Zadrozny - 2006-12-12

        I still have not reported it -- I was waiting until I was able to install Ubuntu here to test it... so, if you can, please report it there.



    • Alan

      Alan - 2006-12-15

      OK, I've reported it.
      If you happen to install Ubuntu Edgy, please try out this behaviour out a fresh Ubuntu install, and then do an update & upgrade. I believe all of this happened after a huge library upgrade that was released for edgy at the end of November.