No editor descriptor

2010-08-21
2013-03-15
  • Joost Rekveld

    Joost Rekveld - 2010-08-21

    Hmm,

    I'm baffled here: I return after a great holiday, ran a ubuntu system update earlier today and now when I open Eclipse for the first time PyDev seems to be gone. All editor windows in my workspace are empty and show me this message: "Could not open the editor: No editor descriptor for id org.python.pydev.editor.PythonEditor".
    If I look in the preferences the Pydev submenu is gone too, but Eclipse won't let me install PyDev since it says it is already installed.

    weird ?
    any insight very welcome…

    ciao,

    Joost.

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2010-08-21

    Not sure what happened there, but it doesn't seem related to Pydev (other than it's missing). You can try uninstalling then reinstalling eclipse again (or maybe just uninstalling pydev so that it accepts a reinstall).

    Cheers,

    Fabio

     
  • Joost Rekveld

    Joost Rekveld - 2010-08-21

    Thanks Fabio,

    still don't know what happened but the problem seems to be gone now.
    - I reinstalled Eclipse, which did not solve the problem (I should probably have deleted more stuff, somewhere else ?)
    - I uninstalled PyDev via Help->Install new software->already installed->uninstall (which in Ubuntu only seems possible by running sudo eclipse)
    - I tried to reinstall PyDev, but I got an error saying it didn't work because it was already installed, which is weird.
    - I did Preferences->Pydev-Interpreter-Python->Apply
    - everything works as before and I  have PyDev 1.5.9.2010063001 installed

    very strange, but I have the feeling this will keep on working fine until the next kernel update or some crucial package update ?

    thanks,

    Joost.

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2010-08-22

    Just a longshot, but maybe what made a difference is that you needed to run with sudo eclipse one time to update something? Anyways, probably related to the way Ubuntu deals with things, not really with Pydev - issues where Pydev doesn't show up are usually issues with Eclipse or the host OS, not really with Pydev - although I can give some tips on that sometimes :)

    Cheers,

    Fabio

     
  • Joost Rekveld

    Joost Rekveld - 2010-08-23

    I think that is a classical forum problem; knowing where else it is better to ask such questions, implies knowing where the problem is, and mostly that's the problem…

     
  • Anonymous - 2010-10-21

    I've had the same problem many times. What I usually do is to "REVERT" the system settings, i.e. set it back to a previous state. Here's how its done:
    1) Select Help> About Eclipse…
    2) From the "About Eclipse" dialog box, press "Installation Details" button
    3) Select the "Installation History" tab
    4) Select one of the previous configurations from the list and press "Revert".

    It doesn't ALWAYS work though, and I don't know why this is so. :(

    Hope this can be of any help next time if it ever happens again (hopefully not)… :)

     
  • Anonymous - 2011-10-06

    i've just had the problem (installing Remote System Explorer End-User Runtime" Plugin) . and reverting to my original config seemed to work. this is on windows 7.

    a bit of an annoyance though. and still no FTP with Eclipse for me….

     
  • Neo

    Neo - 2013-01-05

    The revert button helped me, thanks.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks