lxml (and others) generate import errors

  • Fabio Zadrozny

    Fabio Zadrozny - 2010-06-08

    Can you post the actual code that's failing? Have you checked if those are really in the pythonpath? Have you tried adding them to the forced builtins? See: http://pydev.org/manual_101_interpreter.html for references.



  • Huuuze

    Huuuze - 2010-06-09

    The code is simple:

    from lxml import etree

    The "etree" portion of that line is highlighted as an import error. 

    Based upon your recommendation, I added "lxml" to the Forced Builtins.  Assuming simply adding "lxml" to the Forced Builtins would correct things, I can confirm that PyDev still detects the import as an error.

    And, yes, it's in the PYTHONPATH.  I'm able to import that same line without any errors in a Terminal window running Python.

  • Anonymous - 2012-08-12

    I had the same issue using PyDev 2.6 for Eclipse. I solved it by building lxml from sources, then building a egg, and then copying the egg into dist-packages folder; but I think it is not necessary to build it from sources, if you get the egg, just add it to dist-packages folder and it should work!


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks