PyDev + Google App Engine

  • Daniel

    Daniel - 2009-06-19

    I've just started with the pairing of GAE + PyDev, and it's working almost completely as advertised - which is great!

    The only thing so far that's not is the "Run As" option - I'm not seeing then "PyDev: Google App Run" like is shown at My only options are "Jython unit-test", "Python Coverage", and "Python unit-test".

    The other wizards and tools work fine - and I can run my GAE app if I manually set the "Main Module" path like in the old days - but for some reason this run configuration isn't showing up as a default one. Any ideas?

    • Fabio Zadrozny

      Fabio Zadrozny - 2009-06-19

      Strange, I've checked it here and it works... Are you selecting the source folder that contains the app.yaml file for the run? Which pydev version do you have? If it still doesn't work, please create a bug-report for it and attach a screenshot with the popup that's not working. And also, please check if there's some error in your error log.



    • Paxton Mason

      Paxton Mason - 2009-06-25

      I experienced the same issue.  There was an error message that said something like "Unable to locate C:\Program Files (x86)\google_appengine\".  I reinstalled  GAE in C:\dev\google_appengine and the problem was resolved.  BTW, the previous directory is the default for Vista 64.

    • Paxton Mason

      Paxton Mason - 2009-06-25

      Also, I've noticed that if I run the app and then terminate it, the "Pydev: Google App Run" option disappears from the Run As... and Debug As... menus.

    • brian

      brian - 2009-06-25

      I am also having the same issue.  I've noticed that the GAE functionality doesn't seem to play well with paths that have spaces in them.  For example when sing the automatic "update" functionality the directory path isn't put in quotes and bombs out.  This may be the source of the missing ""PyDev: Google App Run" option (which I am also experiencing).  It seems Paxton Mason was able to get it working when he installed GAE in a directory path that did not haves spaces (ie not "\Program Files\")


    • Panos Lambrianides


      I had the same issue and I am running on a Mac OS 10.5.  The workaround I found is to remove the interpreter and reinstall it via the "Remove" and "New" buttons in the "Python Interpreters" option under eclipse preferences for PyDev.  Then eclipse needs to be restarted.

      This is a pain of course but after reinstalling the interpreter one can also run the application via the  "Run Configurations" option as well/instead.


  • Anonymous - 2010-11-14

    I'm guessing the asker would have figured it out by now but for the benefit of others - to get the "PyDev: Google App Run" menu option you need to right click on the "src" folder not the file icons.

  • Anonymous - 2010-12-20

    Thank you guys! Right-clicking the src folder does give all AppEngine-related actions indeed! :D  PyDev FTW!