Intermittent hang/termination in debug

2006-11-29
2013-03-15
  • atthecorner

    atthecorner - 2006-11-29

    I'm just reporting odd observed behavior with pydev 1.2.5, python 2.5, eclipse 3.2,

    I observed from console output that my code was not executing to completion. It appeared to hang.

    Successive debug runs revealed that the code appeared to hang in different spots.

    The code executed to completion when I did not include the debugger.

    The code executed to completion when I set a breakpoint on exit().

    Crazy.

    -m

     
    • Fabio Zadrozny

      Fabio Zadrozny - 2006-11-30

      There were lots of changes in the synchronization code from 1.2.4 to 1.2.5, so, this might be the problem... do you have some sample code so that I can test it?

       
    • atthecorner

      atthecorner - 2006-12-01

      I'd like to give you small example code but my efforts have been frustrated so far. I've discovered that
      sometimes it successfuly runs to completion. So, it is hard to distinguish when I've isolated code that
      contributed to the problem or just got "lucky". Sigh...

      I realized this morning that premature termination is what I am seeing, at least if the debug display icons can be trusted. I think they can since I can just make several debug runs in quick succession without having to terminate. Notably, the red square turns grey.

      BTW, there is nothing in the error log not that I expected anything to be there.

      I am using eclipse 3.2. I am inclined to move to 3.2.1 at this point, since I saw that someone
      with a problem vaguely reminiscent of this solved their problem that way.

      If the problem turns into a nice hard failure, I'll be back.  By the way, I just discovered the
      bug reporting protocol, which is where I should have initiated this discussion. I will use that
      means in the future.

      -m

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks