PyLint problems in PD 1.2.6 (was OK in 1.2.5)

Tim Wilson
  • Tim Wilson

    Tim Wilson - 2007-02-20

    Since installing PyDev 1.2.6, I have found that PyLint has problems with my import statements.  Re-installed PyDev 1.2.5 and PyLint worked again.

    Specifically, I have statements like

    from import common

    and a directory structure like this:

    where src is added to PyDev's PYTHONPATH (in the project's properties).

    On 1.2.5, this works just fine,
    but on 1.2.6, I get error from PyLint such as
    F0401: 38: Unable to import '' (No module named mylib)

    PyLint works fine from the command line (as long as I remember to set PYTHONPATH).

    My uninformed guess as to what is happening is that PyDev no longer sets PYTHONPATH when running PyLint.

    Anyone got any suggestions?  I like PyDev and I like PyLint...


    • Fabio Zadrozny

      Fabio Zadrozny - 2007-02-20

      Yeap... upgrade to 1.2.7 (that's a known bug and has already been fixed). The update site at sourceforge is not updated (sourceforge is still not available for that after a whole week -- details on how to get 1.2.7 at:\)




Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks