no PyDev perspective in PyDev install on OSX

2011-08-07
2013-03-15
  • Randy Jones

    Randy Jones - 2011-08-07

    I've installed PyDev (tried latest 1.6, latest 2.2 separately) in OSX 10.6.8, Eclipse Helios SR2.  Eclipse is installed (unzipped) in /Applications.
    Once the PyDev install completes and eclipse is restarted, PyDev is not available in Window->Open Perspective and not available in Preferences.  I seems like it has not been installed at all.  I've tried installing through Help->Install New Software and downloading and unzipping directly.  I have verified that the PyDev features and plugins directories are in /Applications/eclipse/features and plugins.

     
  • Randy Jones

    Randy Jones - 2011-08-07

    I realized I was running the 64-bit version of Helios so I downloaded 32-bit Helios, unzipped it into /Applications (moving old one out first) and have the same result.  After installing PyDev, it doesn't show up in eclipse, even though its files were installed.  I tried the same install with 32-bit Indigo, same result, no PyDev perspective.

    I can't believe I'm the only person this has ever happened to.   Thanks!

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2011-08-11

    I'm not sure what may be happening… (seems like a permission issue for me, but I may be wrong).

    Do you have something in your error log? Is PyDev under the eclipse/plugins? If you still cannot make it work, maybe a solution would be getting Aptana Studio 3 (where PyDev is pre-installed) - you can get the standalone version from: http://aptana.com/products/studio3/download

    Cheers,

    Fabio

     
  • Anonymous - 2011-08-24

    I also had this problem.
    I eventually just downloaded the zip folder, unzipped and installed in the dropins folder.

    Mac OSX 10.6.8

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks