Django imports are unresolved

2010-12-09
2013-03-15
  • CreativeChips

    CreativeChips - 2010-12-09

    Hello,

    I am trying to create a new pydev project with django 1.2.3 support on Aptana 2.x, ubuntu 10.04 (in virtualbox, if it matter)

    I have a "src" folder structure from an previous project (from a whole other machine).
    I am trying to use these sources on a new django project.

    Problem is that all the "imports" to django libs are unresolved.

    it seems Aptana doesnt recognize the django at all.
    1. When i try to create a new project, I get an error-dialog saying django is not properly configured and that "import django" should work - which does work! (from the cmd-line, on python, import django, and django.VERSION works just fine)
    2. On the older project (on which the import wont resolve), i "auto-configured" the python interpreter, which added the "dist-packages" folder, which contains the "django" libs. I can see the "django" package on "python" tree on the project-browser(!)

    I tried removing and reinstalling the django, delete older version (now sudo find / -name "django" only finds the one on "python2.6" folder) - nothing works.

    Could anyone have an idea whats wrong?

     
  • ahunor

    ahunor - 2010-12-24

    Greetings

    Have you managed to solve it ? I've lost more than a couple of hours to it, but couldn't manage to fix it. Tried to download django separately, add that folder to the path.
    Any ideas ?

     
  • Fabio Zadrozny

    Fabio Zadrozny - 2010-12-31

    It seems it's not finding django (so, the pythonpath is probably not correct or wasn't restored after installing django). If the pythonpath is already correct, just go to window > preferences > pydev > interpreter python and press 'apply' and choose the interpreter that should have django installed (or add the folder parent folder where django is installed to the pythonpath).

    Cheers,

    Fabio

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks